cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
userhhMvBfHL2C
Constellation

dishwasher dw80k7050us touchpad controls not working

The control panel on my Samsung dishwasher dw80k7050us is no longer responding to any commands. It won’t even power on now. I turn the electricity off then back on after a few minutes or hours, but it is just completely non functional now. I think I bought it in 2017, but cannot find my receipt from Lowe’s. I think I even bought an extended service warranty from them, but without the receipt they won’t even talk to me. Apparently their records only go back 6 months.

Last year I had the same problem but turning the electricity off for a few days fixed it and it worked ok until this past week.

I’m  willing to pay for the repair if there has been a redesign of the malfunctioning part to fix what is obviously a design flaw considering the 25 pages of the same complaint on this community forum.

does anybody know if there has been a fix for this flaw?

1 REPLY 1
Samsung Moderator
Samsung Moderator

Re: dishwasher dw80k7050us touchpad controls not working

Take a look at these troubleshooting steps in the link below.

http://www.samsung.com/us/support/troubleshooting/TSG01001914/


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.

Reply
Loading...