Original topic:

FireTV Cube (gen 2) and S95D = Atmos stuttering audio

(Topic created: 04-22-2024 04:42 PM)
469 Views
MysterC
Asteroid
Options
LED and OLED TVs

I got a shiny new S95D a couple of weeks ago and love it.

 

However i have an issue I'm trying to diagnose.

I have an Amazon FireTV Cube 2nd Generation hooked directly to the S95D box.

When playing content with Atmos audio on any service (I've tested Prime Video, AppleTV+, Netflix and more) the audio will often stutter or cut in and out.

Sometimes it fixes itself if you let it go a few seconds or skip backwards or forwards in the stream, but often it doesn't help.

Before I had the S95D I used a JBL soundbar with my ~2017 Samsung UHD TV and the FireTV Cube worked just fine with Atmos audio.  I am not using that soundbar on the new system.

I've replaced the HDMI cable with a brand new one and it didn't change anything.

My PS5, when set to use Atmos, works just fine.

Both the FireTV and S95D are running the latest firmware and app versions.

Any advice or ideas?

2 Replies
BeneficialSwimmer
Cosmic Ray
Options
LED and OLED TVs
The port may be faulty or your internet may be slow.
MysterC
Asteroid
Options
LED and OLED TVs

I've tried different ports and I have 1 gig symmetrical fiber. 

If it was a streaming bandwidth issue the video would be affected as well and it's not.   It also played back Atmos when connected to the JBL sound bar on the old TV with the same network configuration.

Thank for your answer 

0 Likes
Reply