cancel
Showing results for 
Search instead for 
Did you mean: 
usery32WCfJx6Y
Asteroid

Re: CHG90 Freesync Ultimate Flickering with NVIDIA GPUs

I wanted to report that I found a solution for CHG90 flickering.

 

You have to get this custom utility called CRU and edit the freesync range. It's set to 120-144hz by default which, frankly, seems like an error. 

 

https://www.monitortests.com/forum/Thread-Custom-Resolution-Utility-CRU

 

Once I set it to 50-144hz literally *everything* works perfectly. No flickering on ultimate engine. All games are perfect.

Reply
Loading...
dcasa
Cosmic Ray

Re: CHG90 Freesync Ultimate Flickering with NVIDIA GPUs

@usery32WCfJx6Y 

 

Mine still flickers after changing that range. What is the firmware version of your unit? Mine is m-HG949CCAA-1019.0 and the default (Ultimate) Freesync range was actually set to 48-144 hz, so changing it to 50-144 Hz didn't help at all.

 

Other info about my setup: Windows 10 Home, nVidia GeForce RTX 2070 through DisplayPort, nVidia driver version 425.31.

 

Apps used to test the flickering issue: nVidia G-SYNC Pendulum Demo 1.13 and AMD FreeSync Demo 0.9.1

Reply
Loading...
useriAQNCwradf
Constellation

Re: CHG90 Freesync Ultimate Flickering with NVIDIA GPUs

I have this same problem too. The very first nvidia driver that supported it worked fine with my 1070, and this was even with the stock chg90 firmware. Ever since I updated nvidia drivers, switched to a 2080, and updated to the latest monitor firmware, I get mad flickering regardless of standard or ultimate engine. CRU is useless too. I can't go back to normal v-sync after using freesync for a couple months - the frames are too low and there's too much micro stuttering. RTSS Scanline Sync isn't perfect yet either. I'm hoping either Nvidia or Samsung fix their drivers soon.

 

EDIT: It's also not a windows-exclusive issue, as the flickering still exists on my Manjaro KDE Linux too. I bought a new, vesa-certified displayport 1.4 cable, still flickering. DDU, still flickering. I hope something can be done.

Reply
Loading...
Sieade245
Constellation

Re: CHG90 Freesync Ultimate Flickering with NVIDIA GPUs

***UPDATE***

 

Well...I can well and truly go home with my tail between my legs. Flicker is still there. I had forgotten that the game I was playing Total War Shogun 2, V-sync was turned on. It is a lot smoother with Gsync/ Freesync turn on so it must be doing something...but if I turn Vsync off the flickering comes back. If I disable Gsync/ Freesync and leave Vsync turned on it is not as smooth lots of stuttering so somethings happening.

 

XCOM2 however flickers with Vsync on or off (Gsync turned on). So looks like NOT the cable. I also tried the custom resolution program from above with the settings suggested and also different at 30-144Hz but no difference.

 

I suppose next thing to try is rolling back nvidia drivers to a version we know definietely works. I'll try that tonight. Sorry for getting anyones hopes up. I'll leave the original post below for the UEFI issue fix info.

 

 

 

 

Possible cause/ fix YMMV

 

I got my CHG90 last week. I also noticed that freesync was unusable. Lots of flickering on ultimate mode. I have GTX1080 with latest drivers as of 02/06/19 and also latest CHG90 firmware as of 02/06/19.  I was using a 3m display-port to mini display port lead which I've had for years. The mini displayport end was connected to the monitor and the displayport end was connected to port 1 of the GTX1080. 

 

Today I needed to go into my UEFI bios and I reaslied the Samsung would not do it. Helpfully I had just been in there the day before with my previous monitor connected with same cable so I assumed it was an issue with either the mini-display port in the monitor not being able to do some resolutions/ a sync issue between the GTX1080 and the monitor or the cable itself.

 

I didn't have time to mess about so I grabbed the displayport-displayport cable which came with the CHG90 and used this instead. Importantly, I didn't change ANYTHING else. The UEFI bios screen came straight up. Afterwards I thought....hmmm I wonder if Freesync is any better on normal displayport.

 

Well IT IS!!! All my flickering is gone. All I changed was the cable. Also, before when I used minidisplayport cable, the GTX1080 would default to 120Hz output. Now it defaults to 144Hz. I haven't changed anything else. Maybe it needs to be at 144Hz to work properly without the flicker? No idea.

 

I've had this cable for years so it may not be certified for the latest display port 1.3+ whatever this monitor has. Previously I was using it on a Displayport 1.2 Dell U3415W display although thinking about it..I did have some trouble getting this all working at the start but never gave it a second thought. I'm now going to have to try and find a longer display port to display port cable as I need a longer one to route it nicely under my desk. For now I'll leave the Samsung cable across the desk. It will be interesting when my new on turns up to test it and see if the flickering comes back. If it does....well the problem HAS to be cable related no?

 

I'm not suggesting this is "the fix" but what I am saying is that for my setup, changing the monitor cable has fixed Freesync. Hope this helps.

Reply
Loading...
dcasa
Cosmic Ray

Re: CHG90 Freesync Ultimate Flickering with NVIDIA GPUs

@Sieade245 

Hmm, are you sure the flickering is gone? I'm experiencing this issue even though I'm using the stock DisplayPort cable. Have you tried testing on the nVidia G-SYNC Pendulum and AMD FreeSync demos?

Reply
Loading...
Sieade245
Constellation

Re: CHG90 Freesync Ultimate Flickering with NVIDIA GPUs

Tried a rollback to the first driver verson that supports G-sync. I think this is the WHQL 417.71. I did a clean install using the option in the driver installation. This has not fixed the flicker if anything it now appears to be worse!

Reply
Loading...
dcasa
Cosmic Ray

Re: CHG90 Freesync Ultimate Flickering with NVIDIA GPUs

Since you've ruled out a driver issue that leaves us with the firmware as a possible cause. @useriAQNCwradf mentioned earlier that it was working fine before upgrading the monitor firmware. I'm pretty sure the flickering ocurred on the previous firmware version (1017.1), so we would need to find someone with an older version or somehow get an old firmware file and downgrade our monitors.

 

BTW, the user manual does mention under the FreeSync section "that screen flickering may occur during game play" ... "The screen may flicker depending on the type of graphics card, the game option settings, or the video being played..." and "While you are using the FreeSync function, the screen may flicker due to variation of the output frequency from the graphics card." (page 30), so I wonder if this is actually working as intended.

Reply
Loading...
Sieade245
Constellation

Re: CHG90 Freesync Ultimate Flickering with NVIDIA GPUs

 

 

 

Done some more work on this tonight with some results.
Went back to the latest driver version as old one made it worse
 
1. Tried 8 and 10 bit colour in Nvidia control panel. Did not seem to make any difference. I swapped between them for most of tests below to check that the xtra bandwidth that 10bit colour needs could be a factor but doesn't seem to be.
2. Tried changing from RGB to the YU colour output modes, looked awful and didn't make any difference to flicker.
3. Make a custom profile for the pendulum program and turned everything off (AA/ sampling etc etc) that I could. Made no difference.
4. Changed my displayport cable from port 1 to port 2 on the GTX 1080. Instantly better. Port 1 has noticeable flickering. Port 2 has less flicker. This may sound objective but that's what I can see. I left it in port 2 for them rest of the tests.
5. Manually changed fan speed to minimum in MSI afterburner to see if fan PWM was affecting it (don't want to turn fan off). Then set to max. No differences in either.
6. Overclocked card by +150 to see if clock speed affects it. No noticeable difference. Set back to normal.
7. Changed to "standard" freesync engine. Flickers only very very occasionally now. On port 1 flickers badly
6. Changing output resolution to 120hz. Flicker gone. Yes gone. Watched the pendulum for 5 minutes and changed the camera settings. Changed back to 144hz, flicker back. Tried 100hz but Gsync now disabled in pendulum (still says enabled in nvidia settings). Back to 120hz all working again no flicker...but standard mode is not as smooth as ultimate.
7. Tried a game I've been using for test apart from pendulum. Xcom 2 war of chosen. This flickers really badly for 2 seconds if you go to "load game". Every time in all other tests. Not this time so looks like IT WORKS only in standard freesync engine and at 120hz for me. Tested 10 bit colour too and it still works.
 
Based on this...changing ports that sholudnt make any difference surely?. I've ordered a new displayport 1.4 certified cable should be here tomorrow I'm going to see what happens and run these tests again. Also I swapped back then to my old displayport to minidisplay port cable and tried these tests again tonight. Exactly the same results on pendulum and xcom. Fro some reason I could no longer select 10 bit colour. It would let me change it but it changed straight back when I clicked apply so I think this is probably related to my old cable not being DP 1.2+ certified. Anyway, Xcom was runing at between 28fps and 80fps depending on what I was doing, slower in the menu so loaded up a game and played around for a bit with no AA turned on to speed it up. Still no flickering.
I realise that the OP talks about ultimate freesync mode, however I have been unable to get either mode to work until this point.
 
Anyone else care to try the same? Changing ports on their graphics card and set to 120hz.
 
Also more wierdness. If i turn on windows HDR mode. Pendulum disables Gync (even though still turned on in nvidia). And all the tearing is gone, even with no vsync. I tried this with in all freesync modes set on the samsung, no difference just no tearing. I tested XCOM but it goes back to non-HDR mode and there is still flickering in freesync ultimate. Think this is probably unrelated just a windows HDR quirk maybe because the display is darker in this mode, there is no tearing? Unsure
 
***update***
noticed that the CRU resolution changing thing above only changes the frequencies for the mode you are in right now. So if you go to standard freesync in monitor, the default rates are 120-144hz. I swapped these to the same as the "ultimate" settings of 48-144 and guess what. The flickering returns!!! Now we are getting somewhere. This was working perfectly in standard mode until I changed these now it is the same as the ultimate mode. I wonder if thats the difference between these two modes on the samsung, different frequency ranges. That might explain why I see no flickering in standard because I'm nowhere near 120-144fps and pendulum only works up to 60. I'm going to try and change the ultimate range to 120-144 and see if this problem goes away in ultimate by doing this. This is the reverse of what the chap earlier on said...but it depends on what FPS you're running at i bet. It might also explain why if you have upgraded the monitor firmware it stopped working maybe they changed these ranges so all we might need is the original frequency ranges...BUT that might mean it was never actually working for anyone depending on what FPS they have?
 
***UPDATE***
 
So heres what I've found. If you change the freesync enabled frequency range in the CRU program..that seems to determine when Gsync will be allowed run. So I tried setting it to 59-144. In pendulum I can go under this and there is no flicker. When you set it to 60 the flicker comes back (on either freesync mode). I had to change the settings on both modes independently using CRU in standard and then again in ultimate mode. I reckon thats the only actual difference between these two modes. Standard has a higher default frequency range of 120-144...but if you can get in this range on the FPS (using the slider FPS control in pendulum, you will see flicker). You see it all the time in Ultimate because the default range is 48-144. If you change these ranges, you can basically swap the flicker behaviour of standard and ultimate around which is why I think all it means is the exact same freesync processing just in different ranges.
 
BUT no question, it looks better with freesync turned on....as long as you're not in that sweetspot frequency range where the Samsung seems to do "something extra" and thats when the flickering starts. So really you need to stay out of that range. Now you could set the range to something silly like 30-31hz but then the problem you've got is that if your display is set to 144hz by default, it seems to disable gsync (at least in pendulum). 
 
So to mitigate this you could set it to something like 130-144 and set your display to 144. I've noticed using the onscreen info display that with gync enabled from 120-144hz. In desktop mode it deffo makes the windows smoother so its doing something but no flicker, the samsung only seems to do the "extra bits" when a game is running. Also if you use OSD you can see the frequency changing dynamically. I was able to get XCOM to run in this sweet spot and it started flickering. If I change graphics to lower, and get FPS above 144 or below 120, the flickering stops...but Gsync still enabled just without the extra bits.
 
Not sure what else can be done on this on. I just don't think ultimate "extra bits" (even though they're not just for ultimate if you change frequency range) are going to work for us at the current state of monitor firmware/ nvidia drivers. At least level 1 works ok. Also, by messing with the frequencies, I was able to successfully use 144hz mode on my display without any flicker (as long as I'm not in the 120-144 fps sweet/ bad spot). 
 
The strange thing now though is that even though I've set both ranges to be 120-144hz. I still get flickering at 144hz mode on standard...but not on ultimate. There must be something else that is different somewhere. Might have another look tomorrow. If I spend any more time in the office tonight my wifes going to kill me !
 

 

Reply
Loading...
Sieade245
Constellation

Re: CHG90 Freesync Ultimate Flickering with NVIDIA GPUs

So what from I can tell. The flickering seems to be caused by one/ multiple of the following:

1. When the monitor frequency shifts too much eg from 60hz to 120hz when Nvidia swaps between LFC frame doubling and proper Freesync

2. Anytime you are in the "proper" freesync frequency range

 

Some good news is that LFC on its own seems to work. So what I've done is used the CRU program to cheat a bit so I will hopefully never be/ rarely in the proper freesync sweetspot. Here is what I have done:

 

1. In CRU, use top Edit button and change range limit to 120-144. This sets the dynamic frequency range the monitor will stay in with freesync activated. So if you are at 60fps, Nvidia will use LFC framedoubling and monitor will be at 120hz. 70fps-140hz and so on. I'm not 100% sure but other multiples seem to work so if you're at 40fps, monitor will be at x3=120hz (has to stay in the 120-144 range it won't drop lower than this now)

 

2. In CRU, in extension blocks at bottom. Click on CE-861 and then click edit. Find freesync range and click edit. Change to 100-144hz. This the "proper" freesync range. Anything FPS below this and the Nvidia will try and do LFC frame doubling/ tripling etc. Any FPS higher and I think freesync is just disabled and normal Vsync will kick in (if you have it turned on). I tried setting it to the same as the monitor frequency 120-144 but the nvidia would keep dropping freesync maybe due to the range being too tight.

 

So problem is there may be some FPS where there is not an exact multiple in the monitor frequency range. So for example 75-100fps would need 150-200hz monitor refersh rate to work (at x2 multiple). Normally I think this would either be in the "proper" freesync range and/or the monitor can change its frequency to get lower and to these FPS but I've overridden this. So there is a patch of frequencies not covered by LFC or proper freesync I think 73-120fps. I tried changing the frequencies to include all of these but the flickering comes back. Might keep at it.

 

As the monitor is limited to only 120-1444hz, large frequency changes aren't possible and this seems to get rid of problem 1 above. Obviously if the FPS goes into 120-144 then proper freesync is going to turn on and I'm not sure what to do about this at the moment. There is hardly any flicker left even in this proper freesync range but it might still be there just FPS too high now to see it.

 

Looks good though going to leave it at this at the moment.

 

As I've changed the frequencies in CRU, it doesn't matter if you are in standard or ultimate mode now, I've set them both the same but to start with they were different ranges hence why more flickering in ultimate mode. I'm still not convinced there is any other difference between the modes apart from this at default samsung firmware frequency ranges.

Reply
Loading...
usertZZS7locjT
Constellation

Re: CHG90 Freesync Ultimate Flickering with NVIDIA GPUs

Maybe Samsung and AMD is lieing us. Just take a Look the FreeSync Range listed by AMD, if you go to Radeon Settins Panell it will says what Standard Mode are 120-144Hz meanwhile Ultimate Mode 48-144Hz all this is false, maybe this monitor cant handle the freesync below 72 in Ultimate. This monitor flickers with NVIDIA and AMD trust me.

 

Sin título.png

Reply
Loading...