Original topic:

Change Samsung 860 EVO 4TB from Sata I mode to Sata III mode?

(Topic created on: 3/18/21 4:25 PM)
cjb3bhl0
Constellation
Options
Monitors and Memory

I have an ASRock H310M-STX computer and I added a Samsung 860 EVO 4TB SSD to one of the Sata ports.  The computer's BIOS does not see the SSD (I am running the latest BIOS), but Windows does see it when it boots.  The problem is that Windows seems to put it into SATA I mode.  Magician confirms that AHCI is activated and that the SSD is SATA I.  It also says SATA III is available.

My question is how do I force the drive into SATA III mode?  Is there an IOCTL I can send to the driver or a device specific command that I can send which will transition the drive from SATA I to SATA III?  I don't mind writing a little code to do this if you can give me the programming information.

1 Reply
ddaniel51
Comet
Options
Monitors and Memory

If this is a  second drive then remove the first drive and see if the SSD detection changes.  Swap ports.

What you described appears to be a motherboard/bios versus drives conflict.

 

0 Likes