JUMP TO SOLUTION Solved

Original topic:

LC27RG50 G-Sync inverse ghosting during pan/scroll

(Topic created: 01-04-2021 01:48 PM)
AlCapwn
Asteroid
Options
Monitors and Memory

I just received my LC27RG50 monitor and while it's quite impressive in just about every regard, when trying to use G-Sync with my RTX 2070 over DisplayPort on driver 442.19 I'm having truly horrible inverse ghosting which makes it appear the monitor's brightness/sharpness grealty increases during any pan/scroll action. This issue is happening at even 150fps and doesn't start to go away until you're over 200fps. Even then the issue is still present although it's harder to notice. 

 

On the nvidia website the monitor is listed as having a 48-240hz G-Sync range.

 

https://www.nvidia.com/en-us/geforce/products/g-sync-monitors/specs/

 

I even tried installing the 'driver' offered by Samsung incase it somehow changed something but it's only a color profile.

 

From reading some reviews I know I'm not the only one experiencing this issue with this monitor. I noticed there is a 'service' USB port available so is there any chance in the future there will be a firmware update offered that would fix this? If not I'm sadly going to have to return it.

18 Replies
Samsung_X2GZoyU
Astronaut
Options
Monitors and Memory

I need a verification code

0 Likes
Reply
user1vuXe5zBpc
Constellation
Options
Monitors and Memory
user9jnqqX86XW
Constellation
Options
Monitors and Memory

Got the same exact issue, I really love everything about the monitor except for the gsync it's impossible to play with such tons of inverse ghosting please fix it.. For people who want  tempory fix, create a custome resolution from nvidia control panel and set it to 201HZ the ghosting will go away but STILL I want to use the full refresh rate without ghosting or at least add a separate overdrive option in the OSD in a new firmware!

userCw6gOiLhhp
Constellation
Options
Monitors and Memory

Just bought this monitor and i got exactly the same problem. Setting refresh rate to 200hz is a fix that everyone does i guess yet this is a 240hz "RAPID" monitor lol. They should recall this monitor from shelf and call it 200hz monitor or they have to update firmware with a solid fix. I fell like i got scammed by Samsung.

userWXRfjEhUew
Asteroid
Options
Monitors and Memory

I agree , now running the latest Nvidia drivers - 452.06 , no improvement. 

 

Clearly this monitor is no longer a G-sync monitor.  Was it ever ? 

 

Samsung , what is being done to fix this ? 

0 Likes
Reply
usergdxT1p4gVe
Astronaut
Options
Monitors and Memory

So, I just set up this monitor today and I noticed really bad ghosting while web browsing and scrolling white pages with black text, the text would leave greenish ghosting trails. And I found an odd fix for it which seems to be a bug Samsung may be able to fix with Nvidia or perhaps just a firmware update?

 

I turned Adaptive Sync off -- allowing me to set the refresh speed to "Standard" - I then turned Adaptive Sync back on... And the ghosting is now completely gone. It seems there is an issue with locking the manual refresh rates and then doubling that up within the Adaptive Sync settings. 

 

Can someone from Samsung comment on this ? Thanks.

0 Likes
Reply
user9DGsQsqmtq
Astronaut
Options
Monitors and Memory

Turning off display specific settings in the G-Sync control panel fixed it for me

0 Likes
Reply
userCw6gOiLhhp
Constellation
Options
Monitors and Memory

Because you should enable that option for g-sync to work.

0 Likes
Reply
edyx17
Constellation
Options
Monitors and Memory

Hey guys, I think I have discovered a fix (at least for nvidia cards, i do not have an amd card to test this with). Maybe someone else can try this and confirm it. It seems that by creating a custom resolution with a lower refresh rate the overshoot disappears. I created a custom 1920 x 1080 resolution with a lower value for the refresh rate (222hz seems to have done it in my case, when trying to go over 230hz, the overshoot reappeared)

 

I have tested with nvidia pendulum sync quite a few times sinces i've done this, and the only time the overshoot reappeared was when (by mistake), i started pendulum sync in 1650x1050 fullscreen. Other than that, it seems to have done the trick for me.

 

Hope this helps you.

 

 

Here is a screenshot of my nvidia settings.

image.png

0 Likes
Reply