JUMP TO SOLUTION Solved

Original topic:

Odyssey G9 will not wake up

(Topic created: 10-15-2020 11:12 AM)
usercYMYbjswJl
Cosmic Ray
Options
Monitors and Memory

I am having an issue with my new Odyssey G9 in that after the monitor goes to sleep, it doesn't wake back up.   Windows thinks the monitor is there and shows it in the list of displays.   Pressing Win + Shift + Ctrl + b does fliker the screens, but the monitor does not wake up.

 

It does not appear to be a windows issue because if Windows goes to sleep before the monitor does, then everything comes back.   Only after the monitor times out and goes into power save does this problem surface.

 

The only way I have been able for it to show back up is disconnect the cable or turn the monitor off and then on again.

 

Anyone experiencing this issue?

 

MSI GS65 Stealth

nVidia RTX 2080

Windows 10 v10.0.19041

Connected via DP

usercYMYbjswJl
Cosmic Ray
Options
Monitors and Memory

Thanks for sharing this.   My monitor has always been on the default (Custom), but let me upgrade this firmware and see if that fixes it.    Perhaps on Custom with the older firmware it is an issue but the new firmware only has that problem on Dynamic Contrast??

 

By the way, how did you test this?    For me, it doesn't happen immediately when the computer goes to sleep.    I actually have to let the monitor stay in blank mode for a while before it sleeps.   If I wake up the laptop too soon, it works fine.

 

I will post my results when I try out the new firmware.

0 Likes
Reply
user22OezHnjG4
Asteroid
Options
Monitors and Memory

For me the issue happens every time the computer goes to sleep. So it was easy to replicate. All I had to to do was change the Picture settings and put the computer to sleep. If the monitor came back on after waking the computer up then it was good. Previously the monitor's blue light would turn off indicating it was waking back up but there was no image on the screen and I had to remove the DP and plug it back in to get the signal. By returning to the  default setting, the blue light turned off and the screen woke up with the computer.

0 Likes
Reply
WanaGo
Cosmic Ray
Options
Monitors and Memory

I have this exact same problem too, and yes my monitor is set to Dynamic Contrast too. Using Display Port.

When its sleeping the light is slow blinking, then I move the mouse or touch keyboard, and the screen blinks up for a split second and then turns off. Light no longer flashing. Wait... wait... wait, nothing, will not come back. Ctrl + Shift + Win + B to reset graphics card, and it comes back instantly.

Turned it back to default 'Custom' picture setting, and the problem goes away.

This is definitely a Bug.

Updated firmware yesterday, immediately after receiving the monitor, latest firmware 1006.2 (M-T9549GGAA-1006.2 Model LC49G95TSSEXXY)

0 Likes
Reply
usercYMYbjswJl
Cosmic Ray
Options
Monitors and Memory

Ok, some new information.

 

I immediately had the same problem with 1006.2.     I then switched the firmware to 1005.4 and the problem did get better.  Still it has it's moments, but now when I put my computer to sleep at night then wake it up in the morning, it does come back (sometimes).   

 

There are points of time (and I haven't been able to find the right pattern of events), where it does go black and I have to revert to the power on/off to fix.

 

So far, for me, 1005.4 has been the closest to working; but still not perfect.   That at least tells me it can be fixed with software and it is not a hardware issue.

 

For those of you who have upgraded to 1006.2, you can downgrade by changing the firmware filename to 1006.4xxxxxxxx.img, and then it will let you upgrade.   If you leave it with 1005.4xxxxx.img, then it will complain that the version is older and it will not install.

 

If anyone downgrades theirs from 1006.2, I would like to hear what your experience is with 1005.4.   See if it is similar to what I am finding.

 

 

usercYMYbjswJl
Cosmic Ray
Options
Monitors and Memory

Ok all, I have some more information that might help.

 

With firmware 1005.4 it actually works for me when I sleep the computer and then wake it back up later.

 

What does not work, however, is if the screensaver sleeps.   Then the monitor does not wake up.   I have to power it off, leave it off for about 20-30 seconds, and then turn it back on.    If I don't wait long enough, I have to repeat the process.

 

With firmware 1006.2, the reverse is true.   When the computer is put to sleep, it will not wake up, but when the screensaver turns the monitor off, it seems to come back.

 

This seems to indicate that this problem is a firmware issue.

 

@samsung978531: Can anyone let us know if this has been reported and is being worked?   If not, how do we go about getting this fixed?

 

0 Likes
Reply
Mafius
Constellation
Options
Monitors and Memory

Were you able to solve this issue? I had no issues with other monitor when plugged in to my computer but with the Odyssey G9. It seems to me a firmware issue too...

0 Likes
Reply
Tan-man
Astronaut
Options
Monitors and Memory

The Odyssey G5 has a similar issue. 

 

I fixed this problem for good when I lowered the refresh rate from 144 to 120.  Apparently, you can have a monitor with high refresh rates, but if your graphics card can't handle it, it won't be able to wake it up from sleep.  Try lowering the refresh rate to a lower rate and see if it works. 

 

Most technology systems are as good as its weakest component.  In my case, I had a graphics card that couldn't handle waking up a monitor.  Hopefully, Samsung will fix this issue as you can still use the 144 rate to play games. 

0 Likes
Reply
Mafius
Constellation
Options
Monitors and Memory

This


@Tan-man wrote:

The Odyssey G5 has a similar issue. 

 

I fixed this problem for good when I lowered the refresh rate from 144 to 120.  Apparently, you can have a monitor with high refresh rates, but if your graphics card can't handle it, it won't be able to wake it up from sleep.  Try lowering the refresh rate to a lower rate and see if it works. 

 

Most technology systems are as good as its weakest component.  In my case, I had a graphics card that couldn't handle waking up a monitor.  Hopefully, Samsung will fix this issue as you can still use the 144 rate to play games. 


That does not apply here. I have a 2080 ti and It can perfectly wake up the screen.

0 Likes
Reply
eR0
Astronaut
Options
Monitors and Memory

@Mafius This may not apply to your situation, but I encountered the never-wake-up problem due to using an HDMI connection. When I switched to a USB-C to DisplayPort my monitor woke up upon mouse or keyboard activity. 

 

Best of luck in resolving the issue though!

0 Likes
Reply
usersfgUsuHlBW
Constellation
Options
Monitors and Memory

I have the same issue with the G9 not waking up from sleep.

I have worked out that when the Windows 10 display setting "Windows HD Colour, Use HDR" is turned on, it will not wake up.

If I turn "Use HDR" off, it does wake up.

 

This is definitely a bug somewhere that needs fixing.

0 Likes
Reply