JUMP TO SOLUTION Solved

Original topic:

Samsung 970 Evo M.2 SSD not showing in Disk Management

(Topic created on: 3/17/20 5:37 AM)
userqqx1qY2V1S
Astronaut
Options
Monitors and Memory

Hello, I recently installed a new Samsung 970 evo plus M.2 SSD into my ROG MAXIMUS HERO XI motherboard but I'm having issues using it. It does not show up in file explorer and when i tried to create and format hard disk partitions since i had read online that was the majority of everyones issues I found that mine does not show up. I have tried refreshing, reinstalling it, installing it in both m.2 ssd slots on the motherboard and restarting my computer multiple times to no results. Any help would be greatly appreciated. 

1 Solution


Accepted Solutions
Solution
SamsungBri
Samsung Moderator
Samsung Moderator
Options
Monitors and Memory

Hello! We have a specialized team dedicated to this product line. Their hours of operation are 9 am to 12 am (Monday through Friday) and 9 am to 9 pm on Saturday. You can reach them by calling 800.726.7864 or emailing samsungmemorysupport@sea.samsung.com.


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.





Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

View solution in context

0 Likes
Reply
2 Replies
Solution
SamsungBri
Samsung Moderator
Samsung Moderator
Options
Monitors and Memory

Hello! We have a specialized team dedicated to this product line. Their hours of operation are 9 am to 12 am (Monday through Friday) and 9 am to 9 pm on Saturday. You can reach them by calling 800.726.7864 or emailing samsungmemorysupport@sea.samsung.com.


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.





Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

View solution in context

0 Likes
Reply
ddaniel51
Comet
Options
Monitors and Memory

Does the drive show in the Bios?  Did you look  at the NVME Configuration in Bios?

Both the User and Bios Manual have info on configuring the Mother board and Sata Port usage for proper Sata and NVME operation.

 

Did you install the NVME drivers?

 

 

0 Likes
Reply