Original topic:

Samsung 980 PRO 1TB - slow speed 750-900 MB/s with PCIE 4.0

(Topic created: 06-01-2021 11:22 AM)
Monitors and Memory

Crucial 32GB (2x16GB) DDR4 4000 MHz Ballistix MAX
Windows 10 PRO x 64, USB installed from official Intel site.

Samsung 980 PRO 1 TB is placed in NVME M2_1 PCIe 4.0 processor slot and the read/write speed is about 900/750 MB/s.

It works stable as a secondary SSD.
It doesn't work as the system disk "C" - I get eternal reboots, or blue screens:
Sometimes, after reboot it does get half of speed - 3460/3330 MB/s. Once or twice I saw even normal speed 6700/5000 MB/s.
But most of the times, when the PC is able to start, it gets 900/750 MB/s.

On brand new Windows, with no drivers I get nice speed 6700/5000 MB/s:2021.05.21_14.29 После переустановки Win.PNG 

After installing the official chipset drivers it goes slow - 900/750 MB/s:2021.05.20_17.46 Чистая система, без драйверов.PNG

I tried to connect it into second M2_2 PCIe 3.0 PCH slot - same thing.

The firmware was updated to 3B2QGXA7, using the Samsung Magician.

BIOS is updated, the latest (0707)
I also tried previous (0605, 0402, 0232) - nothing changes.

All the motherboard latest drivers from Asus official site are installed.

First I bought 980 PRO 2TB. It caused the same thing, and I had to return it to the seller. After a while I took the 980 PRO 1TB.

Two disks - same result. So I think both the disks 980 PRO 1 and 2 TB are OK. There must be something about drivers or the way the PC parts mach each other.

As I see, it works in PCIe Gen 1 mode with x4 lines, right?PCIe Gen 1 x 4.JPG
PCIe Gen 1 gives 200 MB/s x 4 = ~800 MB/s.
Why? Maybe I didn't do something I should, or I did something I shouldn't?

The old one Samsung 970 250 GB in these both slots (M2_1 & M2_2) shows PCIe Gen 3 x 4 = 3430/1350 MB/s. It works perfectly:

Диск С 250 ГБ, 2 слот.JPG


Please help 🙂

2 Replies
Monitors and Memory

You have demonstrated the 980 Pro works properly on a clean Win 10 install so the drive is not an issue.

Magician showing the drive connection as pcie Gen 1x4 is a serious problem as it should always be PCIe Gen 4 x4.  This indicates a lack of connection between the 4 pcie lanes from the drive to the  CPU.  Being intermittent in it's operation means it could be the motherboard or CPU causing problems.


You will best be served by going to the ASUS ROG forum for help.


Monitors and Memory

"This indicates a lack of connection between the 4 pcie lanes from the drive to the CPU"

The 970 EVO in the same M2_1 slot gets from the processor all the PCIe Gen 3 x 4 lanes, as needed...
980 PRO should be at least the same 3 x 4, but it's having only 1 x 4...

I forgot to say that when I changed
Crucial 32GB (2x16GB) DDR4 4000 MHz Ballistix MAX

back to the

HyperX DDR4-2400 16384MB PC4-19200 (Kit of 2x8192) Fury Black (HX424C15FB2K2/16)

on clean Win 10, with no updates, no Internet connection, no any drivers installed, only what comes on USB installation, 980 PRO runs well and stable, as the system or non-system disk.
Once the Internet plugged in, or the chipset driver is installed - it gets unstable as disk "C",  the blue screen comes up. But the speed stays 6700/5000 MB/s with HyperX DDR4-2400.

Could the RAM Crucial 32GB Ballistix MAX and 980 PRO plugging on the same motherboard be causing this problem?
As I understand, they both are plugged to CPU directly, without PCH.
Seems like changing the RAM to enother one makes the difference...
In fact, they both don't have official drivers at all 🙂

All separately works well. Together with 980 PRO it doesn't match...

I will write on Asus forum, thank you.
Is there any idea how to switch PCIe Gen 1 x 4 into PCIe Gen 4 x 4 on the 980 PRO?