cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Constellation

Samsung Magician 6.2 update fails

I got notifications to update Magician v6.1 to new v6.2.  Started install but it wants MS Visual C++ 2015 Redistributable (x86).  Tried to install but that failed ... the 2017 version is already installed.  I also find that the 2015 version is not supported in Windows 10 which I have.  Does the update package need to be updated?

 

LL