Original topic:

Samsung Odyssey G70A (S28AG70) - DisplayPort sound issues

(Topic created: 03-30-2022 06:52 AM)
andrebrait
Asteroid
Options
Monitors and Memory

After gathering some data, I decided to report this issue. Me and at least 2 other users are experiencing the same issue. 

 

The issue

Sound on DisplayPort will glitch and pop from time to time (random intervals, ranging from a few seconds to a few minutes). Picture and sound are completely stable and noise-free otherwise. Sound works perfectly on HDMI. I've tried enough cables and devices to isolate the issue to the monitor in conjunction to its firmware. 

The sound glitches are very characteristic of digital noise, similar to stuff I've heard from buffering issues or garbage in memory. It's definitely not analog noise.

EDIT: since I posted this, other users have reported issues on both NVIDIA and AMD graphics cards, and both with pretty much all firmware versions (1004.0, 1005.2, 1006.0, 1008.1). The affected monitors don't respond to firmware updates. It's so weird because the sound works perfectly, otherwise.

 

Tests

See the table below for what combinations of device and input caused issues for me. The other users who reported it were all using PCs with NVIDIA cards. Since the problem only happens on version 1006.0 of the firmware, it's clear the issue is with the monitor's firmware.

When possible, all tests were done using multiple resolutions and a variety of settings, included but not limited to :

  • setting the DisplayPort version to 1.2
  • enabling/disabling power saving features
  • lowering/increasing the volume in the monitor and on the OS
  • multiple OSes (Windows and Linux)
  • multiple drivers (NVIDIA's proprietary drivers and the Open-Source nouveau mesa drivers)
  • lowering/increasing resolution and refresh rates from 1080p@60Hz up to 2160p@144Hz
    • PC (DP 1.4 and HDMI 2.1): from 1080p@60Hz to 2160p@144Hz
    • MacBook (DP 1.4): from 1080p@60Hz to 2160p@144Hz
    • MacBook (HDMI 2.0): from1080p@60Hz to 2160p@60Hz 

So I think it's safe to say the issue lies on the monitor.

What I've tested:

DeviceInputFirmwareSound
PC (Windows/Linux)DP 1.41004.0OK
PC (Windows/Linux)DP 1.41006.0Glitches
PC (Windows/Linux)HDMI 2.11004.0OK
PC (Windows/Linux)HDMI 2.11006.0OK
MacBook ProUSB-C->DP 1.41004.0OK 
MacBook ProUSB-C->DP 1.41006.0OK
MacBook ProUSB-C->HDMI 2.01004.0OK
MacBook ProUSB-C->HDMI 2.01006.0OK

 

How did you get firmware 1006.0?

I had received a unit with 1004.0 and I had to return it due to a stuck pixel. That unit, however, ran totally and completely fine on DisplayPort. Audio was completely fine.

The replacement unit came from the factory with firmware 1006.0.

The other 2 users who reported this to me also received monitors with 1006.0 from the factory.

It's apparently useless to return the monitor because any unit with this firmware version will display the same issue.

16 Replies
userQs6aAsJjM7
Astronaut
Options
Monitors and Memory

Hello, I am one of the mentioned users. I confirm the issue using Display Port. No issue on HDMI. The only difference is that I own an AMD card (RX 590).

@andrebrait thank you for posting this on Samsung forum.

userA5Zv3Dklor
Astronaut
Options
Monitors and Memory

Good morning, my monitor arrived yesterday, the firmware is 1006, also i have the same problem with the audio using the dp port and nvidia video card. I would not have expected such a problem on a product of this range

userquVDaPB8ji
Constellation
Options
Monitors and Memory

I've sadly been dealing with this issue for a few months. I purchased the monitor back in November 2021. I thought issue was my old speakers. I bought new speakers & still was having that issue. I then researched & thought maybe it was the GPU (flickering issue) since I have my PS5 connected to it via HDMI & no issue. I connected my GPU via HDMI & no sound issue. I did end up upgrading my GPU (from 5700XT to 6800XT) & still have that issue. So frustrating. If I connect speaker aux to PC directly & not to the monitor, still leaving PC video connection via Display Port, no problem. The minute I connect aux back to monitor & leave PC video connection through Display Port, the sound issue returns. At this point, I have no clue what it is. I just ended up connecting my PC audio via Bluetooth (bought an adapter to connect speakers from aux to Bluetooth) as far as PS5, whenever I use it, I'll have to connect the aux cable back into monitor. Horrible "fix" as I shouldn't have to be trying everything to get that noise issue to stop. Hopefully a future patch will fix it. I'm currently still on 1004.

0 Likes
andrebrait
Asteroid
Options
Monitors and Memory

Huh, that's weird. You're the first person on 1004 who's reported this. At the same time, I just received a message today from a user on Reddit who's on 1006 and he said he had no issues with DisplayPort at all.

 

So, it seems to be a problem with the monitor themselves?

0 Likes
userquVDaPB8ji
Constellation
Options
Monitors and Memory

That's what I'm going with. I previously had a Viotek GN32DA. No issues with that monitor. Resolution was at 1440p & had it set up the same way I currently have the G70A (except at 4K). I replaced the Display Port cable & even added a noise filter to it along with the power cable just incase, no improvement. I was hoping a firmware update may resolve it, but doesn't seem likely. I thought for a while it may have been an AMD issue but I'm seeing that some folks with Nvidia cards are also being affected. I think it's the monitor/port as the issue. 

0 Likes
andrebrait
Asteroid
Options
Monitors and Memory

That's a bummer then.

Just to be sure, what sort of issues are you seeing? Are the sound artifacts like small loud blips and loud noises from time to time, but a completely clean audio otherwise?

0 Likes
userquVDaPB8ji
Constellation
Options
Monitors and Memory

Audio will be fine & randomly at times a static/pop sound comes in & lasts for like a second. I just came across a post on reddit that firmware 1008 apparently fixes it. I'm going to try & install it on mine. It's from Samsung Korea site since US site is still showing 1004.

0 Likes
andrebrait
Asteroid
Options
Monitors and Memory

Could you post the link to the post here?

And I think you should avoid updating if the model number is different.

0 Likes
userquVDaPB8ji
Constellation
Options
Monitors and Memory
0 Likes