cancel
Showing results for 
Search instead for 
Did you mean: 
Astronaut

Samsung Odyssey G9 display issue at 240hz

I am running at max resolution and when I set the screen to 240hz the right half of my screen gets darker than the left.  I am running a 2080ti videocard and using the display port cable that came with the screen.  Is this a known issue and will a firmware fix this? If I set to 120hz the color issue goes away and all is well.

6 REPLIES 6

Re: Samsung Odyssey G9 display issue at 240hz

I have had the same issue. Sometimes I get it when viewing HDR content, when HDR is enabled. If I turn off HDR, it goes away. It appears to be a bug. I would contact Samsung Support.

Reply
Loading...
Asteroid

Re: Samsung Odyssey G9 display issue at 240hz

Did you contact   support and get your issue fixed Absolute?


@AbsoluteFahrenheit wrote:

I have had the same issue. Sometimes I get it when viewing HDR content, when HDR is enabled. If I turn off HDR, it goes away. It appears to be a bug. I would contact Samsung Support.


 

Reply
Loading...
Asteroid

Re: Samsung Odyssey G9 display issue at 240hz

I also have this issue! RTX 2070 super is what i have. It's only at 240hz setting as well as soon as i bump the refresh to 120hz it goes away. So frustrating. Im running the latest firmware update and everything.

Reply
Loading...
Asteroid

Re: Samsung Odyssey G9 display issue at 240hz

Same issue as well.

Reply
Loading...
Asteroid

Re: Samsung Odyssey G9 display issue at 240hz

Hi

Try to  update  the firmware to 1008.1 : you need a USB Key 3.0 or 3.1 format .

I've used Sandisk USB Key : USB 3.0 SanDisk Ultra 32 Go

and the file name for last Firmawer version (1008.1) is M-T9549GGAA-1008.1[205C] with img extension

Reply
Loading...
Asteroid

Re: Samsung Odyssey G9 display issue at 240hz

I updated the firmware to 1008.1, how to I flash back to the previous firmware to reinstall the 1008.1 update? I've saved the update to my usb 3.0 and when I try to reinstall it it says my monitor is already on a newer firmware and doesn't give me the option to re install

Reply
Loading...