Original topic:

Samsung SSD Firmware Update Utility 3.1 doesn't see my drive

(Topic created: 12-03-2021 04:53 PM)
userm5DYLRjqyj
Astronaut
Options
Monitors and Memory

I have a Samsung SSD 860 QVO that is having some performance issues on my 2012 MacPro 5,1 running OSX 10.13 (High Sierra). I thought I'd check update the firmware to see whether that might be the issue. I followed the instructions in the Firmware Installation Guide to create a bootable USB drive using the appropriate SATA SSD-870 QVO Firmware for Mac driver. 

I was able to boot from the USB and run the Update Utility. However, it went from Scanning... to Press any key to restart... in about five seconds. It never found the drive, mounted in a regular drive bay in my Mac. 

Things I've tried:

   Using another Mac: same result

   Using a PC: same result

   Removing all other SATA drives: same result

   Using Samsung Magician to update the driver from RVQ01B6Q to RVQ02B6Q. I assume that since this was done from Windows, the PC (and not the Mac) version of the driver was installed, but I don't know how I'd be able to tell. Note: This did not fix the performance issue.

   Creating a FAT partition on the drive, thinking this might help the utility recognise the drive.

   Formatting the partition in NTFS, thinking this might help the utility recognise the drive.

After all that, the utility still doesn't even recognise there is a Samsung SSD installed. 

What else can I try? 

What is the difference between the standard and Mac firmware images?

 

0 Likes
0 Replies