Showing results for 
Search instead for 
Did you mean: 

[Unsolved] Samsung SSD Write Speeds SLOW

Am using Windows 10 x64 1809.


I am using P5Q Pro,

North Bridge Intel Eaglelake P45, 

South Bridge: Intel 82801JR ICH10R


Samsung 840 Pro was down to half the write speed it was, probably down to 12 mbps write on large file transers, as it was previously.



Diskmark AHCI Write 105.png


Diskmark AHCI Write 272.png


The solution? Switching from AHCI to IDE, loading into safe mode, booting into windows. Then rebooting, enabling AHCI, booting into safmode, then booting into windows.


This is the scond time this happend, this is the only solution for me. If you do not have IDE mode, you may have to reinstall your SATA drivers manually.  The process outlined above basically reinstalls the windows drivers; The IDE drivers are Marvelle, the SATA drivers are intel. Something is messing up the drives, it would APPEAR. 


This seems to have happened fairly randomly. I suspected some kind of AHCI rootkit previously that is disloged and or wiped when switching back and fourth, though I cannot prove this. However, I did see a screen flicker/flash that made me suspect some kind of intrusion. 




Re: [Solved yet again] Samsung SSD Write Speeds SLOW

Why switch from AHCI to IDE?AHCI is much better for optimizing SSD performance while IDE is always the default option during installing an HDD.

Besides that, you need to ensure TRIM is running. It is well known that any SSD has to clean the data which is marked for deletion before you can add new data on it, but the cleaning process will cost much time. And thus the SSD speed will drop down when it is writing. So TRIM technology is introduced with the purpose of empowering the OS to tell the SSD which data blocks are unnecessary and can be deleted, and then automatically wipe them, so that it will speed up data writing.

Step 1: Type cmd in Windows search. Once the cmd program appears, right click it and select Run as administrator.

Step 2: Then, in the Command Prompt window, type this command: fsutil behavior query disabledeletenotify.

Step 3: Press Enter, after a short while, Command Prompt will display one of the following two messages:

“NTFS DisableDeleteNotify = 0”: means the TRIM is enabled on your SSD.

“NTFS DisableDeleteNotify = 1”: means the TRIM is disabled on your SSD.

If you get the second message, you need to input the command: fsutil behavior set disabledeletenotify 0, and press Enter on your keyboard to enable it.

At last, you can align partitions on the slow SSD drive through a powerful SSD optimization utility.


Re: [Solved yet again] Samsung SSD Write Speeds SLOW

problem remains... the fix was only temporary and lasted for a very short period of time.


Before and after photos