JUMP TO SOLUTION Solved

Original topic:

samsung evo 860 500gb not performing well

(Topic created: 10-19-2020 01:15 PM)
userrt1IGiI9KM
Asteroid
Options
Monitors and Memory

I just got this ssd and along with samsung magician.  Both firmware and magician are up to date.   My read speed is 284MB/s.  Seems way slow. I do have TRIM on via performance optimization.  Nothing seems to help.  I ran with CrystalDiskMark 7.0 and get same results.  Suggestionsssd_trim.JPGssd_perf.JPGssd_version.JPG

1 Solution


Accepted Solutions
Solution
userrt1IGiI9KM
Asteroid
Options
Monitors and Memory

The Samsung phone support was helpful. He said I needed AHCI (which did not help).  But it did lead me to google and the solution is I needed to downgrade my bios to A15.  The later ones (A16-A18) all indicate my SATA is II. With A15, I get SATA III and Magician now reports Sata III and 550+MB/s speeds.    Now closing this topic.

View solution in context

0 Likes
Reply
4 Replies
Options
Monitors and Memory

Hello userrt1IGiI9KM,

What is the model of the computer? Do you know if your computer is using a SATA 3 connection for the storage drive?

0 Likes
Reply
userrt1IGiI9KM
Asteroid
Options
Monitors and Memory

@Memory Product Expert -1  wrote:

Hello userrt1IGiI9KM,

What is the model of the computer? Do you know if your computer is using a SATA 3 connection for the storage drive?

 

Dell xps14 L421X and yes it has SATA3


 

0 Likes
Reply
Options
Monitors and Memory

Helllo userrt1IGiI9KM,

 

Have you checked to see if there are any new drivers available from Dell website for the SATA ports on your motherboard? The speeds you are getting are SATA 2 speeds pretty much, there might be something bottlenecking the drive.

 

You can also contact Samsung by calling 1-800-726-7864 and asking for memory support. They will send you an email to start a ticket and have the drive checked out

0 Likes
Reply
Solution
userrt1IGiI9KM
Asteroid
Options
Monitors and Memory

The Samsung phone support was helpful. He said I needed AHCI (which did not help).  But it did lead me to google and the solution is I needed to downgrade my bios to A15.  The later ones (A16-A18) all indicate my SATA is II. With A15, I get SATA III and Magician now reports Sata III and 550+MB/s speeds.    Now closing this topic.

View solution in context

0 Likes
Reply