cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
user4zrlCB5gTi
Asteroid

[solved] SLOW write speed on Samsung 840 Pro

JUMP TO SOLUTION

So I had this strange issue with my drive. 

 

 

Speeds would dwindle down to 12.5 mb persecond coping 10+ gigabyte files. The burst speed was enough to be largely unnoticable in every day operations. 

 

I was consistently getting half the write speeds than the read speeds; sometimes as low as 90 mbps write; however realworld tests were much worse.

 

All device manager settings were optimal, nothing out of the norm; tried disabling Antivirus and other realtime gadgets to no avail; So I tried disabling AHCI in my BIOS and switching to IDE, (my motherboard is nearly 11 years old already and I still have this option. In windows 10 you must boot into safemode first else your drive will not be detected and you will get a bluescreen upon boot; make sure to select boot into safemode prior to restarting or enable legacy mode for boot options 

just to save yourself the trouble later; you will need this when switching both in and out of IDE/ACHI mode. 

 

So I disabled AHCI, booted into windows, my read and write speeds were FULL speed (for SATA2) 280 mb/s, however many of the benchmarks were slow 30-40 mbps austensible because NCI and other AHCI only features were disabled. So I then rebooted and re-enabled AHCI mode, then booted back into safemode so windows could install the proper drivers, then I rebooted back into windows; now my speeds were back to normal!

 

I am not sure what caused this issue to begin with but it appears to be a driver issue; I did suspect last year, that I may have had some kind of firmware/hardware rootkit in my AHCI controller or something of the sort; for after switching from AHCI to IDE strange things began happening; stuttering upon loading windows, following a sudden reboot by my router; as well as strange ARP spoofing activity coming from the router as well designated as suspicious by XArp. So perhaps that has something to do with it, and switching to IDE flushed out whatever was in the memory, perhaps not, perhaps its just a simple driver issue. When using ACHI it uses an intel chipset, when using IDE it uses a marvelle chipset. Either way, it worked and I'm a happy camper.

 

Fixed now:

 

1 SOLUTION

Accepted Solutions
user4zrlCB5gTi
Asteroid

Re: [solved] SLOW write speed on Samsung 840 Pro

JUMP TO SOLUTION

I know you may not have the IDE option... check your bios and see what is availalb, but perhaps a simple re-install of the driver in device manager will do the trick for you; give that a shot and see if it helps;  Do a manual install, (update), search manually and reinstall it.

 

other things I had done that may have triggered this was manually modifying the registry aistore settings to allow switching from IDE to AHCI, similarly to how it is done in windows 7, those tutorials that I found and used online did NOT WORK, the only one that worked was booting into safe mode. Maybe these modifications had something to do with it and maybe the reinstalling of the driver via switching between ide/ahci did fixed this, or some other reason; try reinstalling your driver and see if that helps.

Reply
Loading...
1 REPLY 1
user4zrlCB5gTi
Asteroid

Re: [solved] SLOW write speed on Samsung 840 Pro

JUMP TO SOLUTION

I know you may not have the IDE option... check your bios and see what is availalb, but perhaps a simple re-install of the driver in device manager will do the trick for you; give that a shot and see if it helps;  Do a manual install, (update), search manually and reinstall it.

 

other things I had done that may have triggered this was manually modifying the registry aistore settings to allow switching from IDE to AHCI, similarly to how it is done in windows 7, those tutorials that I found and used online did NOT WORK, the only one that worked was booting into safe mode. Maybe these modifications had something to do with it and maybe the reinstalling of the driver via switching between ide/ahci did fixed this, or some other reason; try reinstalling your driver and see if that helps.

Reply
Loading...