cancel
Showing results for 
Search instead for 
Did you mean: 
sirsamsmith
Constellation

I have only 4G/3G/2G, Not LTE.

I'm with Bell the fastest network across Canada ( I really experienced it). As you guys all know, Bell has the fastest network but with my recent purchase of Galaxy Note 10+ I like neither Bell nor Samsung. On my Note 10+, LTE is totally missing. It shows only 4G/3G/2G, I couldn't bring LTE back to device. My calls are dropping, my data disconnect and the bars for the network coverage get to ZERO and it takes about 15 sec to 4G+ appear on the top of the screen. My wife's phone(S10+) has full coverage with LTE+ I'm sitting next to her, have 4G with only 2 bars. I don't get it my phone has the 5G ability but Nokia 1100 works better. I took it to Bell's service and they test my phone for 15 mins and finally gave me a new SIM and I still have the issue. I took it to Samsung store, the first question was "Where did you get it from?" I said "From Dubai". The guy couldn't help me because the phone was purchased out of Canada. Like, are you serious? I don't know what to do. So, I've decided to come her and seek some help, please.

3 REPLIES 3
user99ErLhPZtB
Constellation

Re: I have only 4G/3G/2G, Not LTE.

Hello,

 

It seems like your phone from United Arab Emirates simply searches for other frequency bands that the ones available for the different carriers networks in your country. 

Every country has it's own list of frequency bands that are available for all its network carriers. When a manufacturer creates a new phone and starts selling it worldwide, they make sure the series they send to a country will be ENTIRELY compatible with the network.

That is why your Arab Galaxy Note 10+ doesn't work with LT  in Canada. You can check this information by comparing the informations on the phone box with your carrier.

 

The first evidence that led me to this conclusion is that you say your phone displays 4G instead of LTE... They are the same things but with two designations depending on the area you are. Example, I'm French and here, we say 2G, 3G, 4G, 4G+...

I know in Americas, you say (if I'm not wrong): G, E, 3G, H, LTE, LTE+.

 

The only solution I see for you would be to sale your phone, or see directly with Samsung if you can return it and they give you back a Canada variant of your Galaxy Note 10+.

 

I'm truly sorry for the length of my answer, hope it helped Smiley Happy

Reply
Loading...
Anonymous
Not applicable

Re: I have only 4G/3G/2G, Not LTE.


@sirsamsmith wrote:

I'm with Bell the fastest network across Canada ( I really experienced it). As you guys all know, Bell has the fastest network but with my recent purchase of Galaxy Note 10+ I like neither Bell nor Samsung. On my Note 10+, LTE is totally missing. It shows only 4G/3G/2G, I couldn't bring LTE back to device. My calls are dropping, my data disconnect and the bars for the network coverage get to ZERO and it takes about 15 sec to 4G+ appear on the top of the screen. My wife's phone(S10+) has full coverage with LTE+ I'm sitting next to her, have 4G with only 2 bars. I don't get it my phone has the 5G ability but Nokia 1100 works better. I took it to Bell's service and they test my phone for 15 mins and finally gave me a new SIM and I still have the issue. I took it to Samsung store, the first question was "Where did you get it from?" I said "From Dubai". The guy couldn't help me because the phone was purchased out of Canada. Like, are you serious? I don't know what to do. So, I've decided to come her and seek some help, please.


Perhaps you didn't configure your device for the SIM-card you use now and the country you are in now ?

Try this :

- switch off

- remove sim card

- start

- do a factory reset

- switch off

- add sim card

- start

- agree when asked whther it should configure for canada

- proceed with installation

Reply
Loading...
Supernova

Re: I have only 4G/3G/2G, Not LTE.


@sirsamsmith wrote:

I'm with Bell the fastest network across Canada ( I really experienced it). As you guys all know, Bell has the fastest network but with my recent purchase of Galaxy Note 10+ I like neither Bell nor Samsung. On my Note 10+, LTE is totally missing. It shows only 4G/3G/2G, I couldn't bring LTE back to device. My calls are dropping, my data disconnect and the bars for the network coverage get to ZERO and it takes about 15 sec to 4G+ appear on the top of the screen. My wife's phone(S10+) has full coverage with LTE+ I'm sitting next to her, have 4G with only 2 bars. I don't get it my phone has the 5G ability but Nokia 1100 works better. I took it to Bell's service and they test my phone for 15 mins and finally gave me a new SIM and I still have the issue. I took it to Samsung store, the first question was "Where did you get it from?" I said "From Dubai". The guy couldn't help me because the phone was purchased out of Canada. Like, are you serious? I don't know what to do. So, I've decided to come her and seek some help, please.


@sirsamsmith 

 

Try APN reset:

Go to: settings>connections>mobile networks and check settings there. Then go to access point names.  Make sure proper carrier is selected and tap 3 dots on top right and do reset to defaults.   

If you want LTE to show, then you may have to flash EU firmware that has LTE in the system but even then if the physical cellular bands aren't fully compatible with your carrier, then your phone won't have all the features like Canadian phones will.


Reply
Loading...