cancel
Showing results for 
Search instead for 
Did you mean: 
SARCtech
Cosmic Ray

WiFi Calling not working properly

I have WiFi calling enabled with WiFi calling set as preferred.  The problem is that WiFi calling is not working properly.  My office is in my basement where I typically have very low to no signal on the mobile network.  My calls are constantly being dropped and I mainly notice this on incoming calls.   When the call drops I get the message "No Signal".   It sometimes even happens on outgoing calls though those are usually pretty stable and show the icon for WiFi calling.  Secondly, I keep getting a notification that my setting is being changed to "mobile network preferred" to "optimize call quality".  I have to keep going in and changing the setting back to WiFi preferred.

 

I never had this issue on my Google Pixel 2 XL.  WiFi calling worked flawlessly for both incoming and outgoing calls.  My WiFi signal is excellent so it isn't an issue with my WiFi in my home.  This problem has just started after switching to my new Note 10+ and is very annoying.

-----------------------------------------------------------------------------------
Device: Samsung Galaxy Note 10 + (Unlocked)
Network: Mint Mobile MVNO (T-Mobile Network)
10 REPLIES 10
Samsung Care Ambassador

Re: WiFi Calling not working properly

@SARCtech Does this happen to any wifi connection other than your office?




═════════════════════════════════════
If you post new question please specify your Phone model and Carrier.
If you like my comment please hit ♥
if I answer your question please hit the 'accept as solution' button
Reply
Loading...
SARCtech
Cosmic Ray

Re: WiFi Calling not working properly

No but I dont use the phone that much on other WiFi connections.   As I said my WiFi connection is good.  Wife has a Pixel 2XL and I had the same before I had my Galaxy Note 10+ and WiFi calling performance was and has been flawless with those devices.   The Note 10+ seems to be the only one that's having an issue.  It drops calls like crazy and when it does it says "No Signal" which tells me it's not using WiFi calling for incoming calls even though I have specified for it to prefer WiFi calling in the settings.  When I make an outgoing call it shows a WiFi calling icon in the notification area and I haven't noticed a problem there.  The problem is definitely specific to my phone as nothing else has changed.

-----------------------------------------------------------------------------------
Device: Samsung Galaxy Note 10 + (Unlocked)
Network: Mint Mobile MVNO (T-Mobile Network)
Reply
Loading...
Samsung Care Ambassador

Re: WiFi Calling not working properly

@SARCtech wifi calling relies on your router connection. The router is not design for VoIP call so the prioty is lesser. Try to turn on airplane mode and switch wifi on this will force all calls to wifi and try that. Also try this to any other wifi like starbucks and see if the issue ony in your office.




═════════════════════════════════════
If you post new question please specify your Phone model and Carrier.
If you like my comment please hit ♥
if I answer your question please hit the 'accept as solution' button
Reply
Loading...
SARCtech
Cosmic Ray

Re: WiFi Calling not working properly


@RedDragon wrote:

@SARCtech wifi calling relies on your router connection. The router is not design for VoIP call so the prioty is lesser. Try to turn on airplane mode and switch wifi on this will force all calls to wifi and try that. Also try this to any other wifi like starbucks and see if the issue ony in your office.


I appreciate your response and mean no disrespect here.  I am well aware how WiFi calling and voice over iP works.  The problem is NOT with my router or anything else with my home network setup.

 

1)  I have two other devices using Wifi calling flawlessly on the same mobile network and same wifi network (Pixel 2 XL and an iPhone XR).  The other devices do not have this problem at all.  I also have a voip adapter that I use for my home phone that again works flawlessly with my setup.  The only device having a problem here is my Note 10 +

 

2)  If I have my device setup for wifi calling with wifi preferred then both incoming and outgoing calls should be routed via the wifi and not the mobile network when I am connected to wifi.  This is clearly not happening with incoming calls which is why I am having a problem.  This appears to be a software issue with the Note 10 + where it is not routing calls properly.   I suppose disabling the mobile network would work but I am pretty sure that would stop my incoming calls because again they are coming in via the mobile network and not the wifi even though that is how I have the device configured. 

 

3)  The last issue is why does my phone constantly keep changing my setting from wifi preferred to mobile network preferred?  This usually happens when I leave the house and go out.  It will switch it automatically and notify me it has done so.  I then have to go in and switch it back.

 

The whole reason I'm using wifi calling is because it's more reliable than the mobile network coverage in my area.  This is deeply frustrating to me that the phone is configured to do one thing and it's not doing what its supposed to do.

-----------------------------------------------------------------------------------
Device: Samsung Galaxy Note 10 + (Unlocked)
Network: Mint Mobile MVNO (T-Mobile Network)
Reply
Loading...
Samsung Care Ambassador

Re: WiFi Calling not working properly

@SARCtech Well I though you know well about wifi calling but seems not well enough. Since the oreo update Wifi calling has been updated to force to mobile network because wifi calling is not reliable because the internet and router is not design for VoIP it will make choppy and breakout calls thats why I asked if it does the same thing on other router so we can sort out if the issue is your router. As of now T-Mobile updates their phone to for to Mobile network first before it hit wifi-calling. Your phone seems to route all calls to mobile first before it drops to wifi that is also why I asked you to turn on Airplane mode to allow/force calls to route to wifi.




═════════════════════════════════════
If you post new question please specify your Phone model and Carrier.
If you like my comment please hit ♥
if I answer your question please hit the 'accept as solution' button
Reply
Loading...
SARCtech
Cosmic Ray

Re: WiFi Calling not working properly


@RedDragon wrote:

@SARCtech Well I though you know well about wifi calling but seems not well enough. Since the oreo update Wifi calling has been updated to force to mobile network because wifi calling is not reliable because the internet and router is not design for VoIP it will make choppy and breakout calls thats why I asked if it does the same thing on other router so we can sort out if the issue is your router. As of now T-Mobile updates their phone to for to Mobile network first before it hit wifi-calling. Your phone seems to route all calls to mobile first before it drops to wifi that is also why I asked you to turn on Airplane mode to allow/force calls to route to wifi.


I know enough about wifi calling to know it works on both Pixel 2 XL with android Pie and iPhone XR with ios 12.  On both of those devices "tmobile wifi calling" is displayed in the top left corner of the lock screen whenever they are connected to wifi.  As I said before wifi calling works perfectly on those devices.  How do you explain the fact that wifi calling has worked fine for the past year + on both of the above devices and on my previous device which was also a Google pixel 2 XL with android pie?  

 

As far as routers go every modern router made in the last few years have basic quality of service features (some more advanced) which will prioritize latency sensitive traffic such as voip and streaming video.  I am using a google wifi mesh system and it works flawlessly on my 100 megabit fiber connection.

 

Based on the above information and basic process of deduction I will say again the problem is with the Note 10 + and not with any other equipment. 

-----------------------------------------------------------------------------------
Device: Samsung Galaxy Note 10 + (Unlocked)
Network: Mint Mobile MVNO (T-Mobile Network)
Reply
Loading...
Neutron Star

Re: WiFi Calling not working properly


@SARCtech wrote:

@RedDragon wrote:

@SARCtech wifi calling relies on your router connection. The router is not design for VoIP call so the prioty is lesser. Try to turn on airplane mode and switch wifi on this will force all calls to wifi and try that. Also try this to any other wifi like starbucks and see if the issue ony in your office.


I appreciate your response and mean no disrespect here.  I am well aware how WiFi calling and voice over iP works.  The problem is NOT with my router or anything else with my home network setup.

 

1)  I have two other devices using Wifi calling flawlessly on the same mobile network and same wifi network (Pixel 2 XL and an iPhone XR).  The other devices do not have this problem at all.  I also have a voip adapter that I use for my home phone that again works flawlessly with my setup.  The only device having a problem here is my Note 10 +

 

2)  If I have my device setup for wifi calling with wifi preferred then both incoming and outgoing calls should be routed via the wifi and not the mobile network when I am connected to wifi.  This is clearly not happening with incoming calls which is why I am having a problem.  This appears to be a software issue with the Note 10 + where it is not routing calls properly.   I suppose disabling the mobile network would work but I am pretty sure that would stop my incoming calls because again they are coming in via the mobile network and not the wifi even though that is how I have the device configured. 

 

3)  The last issue is why does my phone constantly keep changing my setting from wifi preferred to mobile network preferred?  This usually happens when I leave the house and go out.  It will switch it automatically and notify me it has done so.  I then have to go in and switch it back.

 

The whole reason I'm using wifi calling is because it's more reliable than the mobile network coverage in my area.  This is deeply frustrating to me that the phone is configured to do one thing and it's not doing what its supposed to do.


Go to settings>connections>wifi>advanced and there few options on top of the list - check them out

Check if your phone is not setup for Private DNS: settings>connections>more connections settings>

Reply
Loading...
SARCtech
Cosmic Ray

Re: WiFi Calling not working properly

Charkatak thank you for the reply.  I do have private DNS enabled using adguard DNS to filter out ads.  Do you think private DNS could be causing this issue?  I will do some more troubleshooting tonight to both force wifi calling and disable private DNS to see where that gets me.

-----------------------------------------------------------------------------------
Device: Samsung Galaxy Note 10 + (Unlocked)
Network: Mint Mobile MVNO (T-Mobile Network)
Reply
Loading...
SARCtech
Cosmic Ray

Re: WiFi Calling not working properly

UPDATE:

 

I have done further troubleshooting.  This is not a bug in private DNS.  This problem is caused by using Adguard DNS servers (used to block ads).  Apparently adguard is blocking something in their DNS which causes WiFi calling to break for incoming calls on Samsung devices only.  I suspect it might be the Hiya integration but I can't prove that.  It does not affect my other devices.

 

I had them setup as private dns "dns.adguard.com" and disabling that resolved my issue.  Just for kicks I set my router DNS to adguard servers and sure enough it broke WiFi calling on my Samsung device only and only for incoming calls.

 

So this is not a problem with any of the above.  It is a problem with Adguard dns servers blocking something that Samsung device needs to get the incoming wifi call.  I really don't have time to trace down further what exactly is being blocked.

-----------------------------------------------------------------------------------
Device: Samsung Galaxy Note 10 + (Unlocked)
Network: Mint Mobile MVNO (T-Mobile Network)
Reply
Loading...