JUMP TO SOLUTION Solved

Original topic:

Note20 Ultra slow to connect to mobile data and slow connection speeds

(Topic created on: 4/16/21 2:57 PM)
jegsurf
Asteroid
Options
Note20

I have a note 20 ultra and I have mobile network connection problems very slow to connect. I have all the bars and the 5G connection and can have a 70 to 80 dBm signal strength but still takes a very long time to connect and start loading data. I have had the phone since December and only about 3 times have I had speeds about 200 to 400. I live in Houston TX on T-Mobile. I bought my phone from Samsung unlocked

1 Solution


Accepted Solutions
Solution
SamsungQue
Samsung Moderator
Samsung Moderator
Options
Note20

I would like to look into this issue further for you. Can you send me a private message using this link here? (http://bit.ly/2HP0oRi) Provide the following information.

  • Model number
  • IMEI number

View solution in context

0 Likes
Reply
10 Replies
jegsurf
Asteroid
Options
Note20
I wish I would have returned it immediately instead of waiting for updates
0 Likes
Reply
SamsungQue
Samsung Moderator
Samsung Moderator
Options
Note20

Have you tried swapping out the sim card in your phone?

0 Likes
Reply
jegsurf
Asteroid
Options
Note20
Yes I've got a new one two time. I got a new one three days ago and no luck.
0 Likes
Reply
jegsurf
Asteroid
Options
Note20
Once I was getting 20 to 40 mbps and I reset the network about 5 times by hitting the reset button again and again until it showed it reset it about 5 times. After that I got speeds of 200 to 400 mbps for a little while
0 Likes
Reply
Solution
SamsungQue
Samsung Moderator
Samsung Moderator
Options
Note20

I would like to look into this issue further for you. Can you send me a private message using this link here? (http://bit.ly/2HP0oRi) Provide the following information.

  • Model number
  • IMEI number

View solution in context

0 Likes
Reply
jegsurf
Asteroid
Options
Note20
Ok
0 Likes
Reply
jegsurf
Asteroid
Options
Note20
I sent it to you
0 Likes
Reply
SamsungRei
Samsung Moderator
Samsung Moderator
Options
Note20

Thank you. We have received your private message and will follow up with you there. 



Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.



Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

0 Likes
Reply
AG6
Galaxy
Options
Note20
Sometimes turning off 5G and going with LTE helps.

Settings>connections>mobile networks>network mode
0 Likes
Reply