cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Astronaut

Samsung Messages

JUMP TO SOLUTION
So my wife and I both had S9 phones and needed to replace them. She wanted to go back to an IPhone but decided to stick with Samsung because we liked both having androids so we could use read receipt, which made it really convenient to see if we had opened a text or not. So I got the Note 20 ultra and she got the S20. Low and behold...read receipt is gone...and when she tries to switch to messages by Google the chat features will not work. (Mine works fine) It has been stuck on "verifying phone number" for a week. Why would samsung delete features on a new phone? Does anyone have any other ideas that may help? I have looked all over forums and YouTube videos and nothing is working.

Any help would be appreciated! We are very disappointed in Samsung though.
1 SOLUTION

Accepted Solutions
Highlighted
Cosmic Ray

Re: Samsung Messages

JUMP TO SOLUTION
Try this trick. get phone by Google. set as default. press *#*#467#*#*. then ims service switch and enable rcs switch. then scroll down to rcs and enable everything under rcs. then go back one in the menu and select rcs configuration. make sure the two settings are set to always connect. once that is good then go to the main settings then app then messages. force stop and clear cache. open up samsung messages and you should have new settings either advanced or chat settings should appear. hope this helps.

View solution in original post

Reply
Loading...
12 REPLIES 12
Highlighted
Cosmic Ray

Re: Samsung Messages

JUMP TO SOLUTION
I have the S20 myself and the read receipts option is still available. it is an option on the chat settings that you can toggle on or off.
Reply
Loading...
Highlighted
Cosmic Ray

Re: Samsung Messages

JUMP TO SOLUTION
Try this trick. get phone by Google. set as default. press *#*#467#*#*. then ims service switch and enable rcs switch. then scroll down to rcs and enable everything under rcs. then go back one in the menu and select rcs configuration. make sure the two settings are set to always connect. once that is good then go to the main settings then app then messages. force stop and clear cache. open up samsung messages and you should have new settings either advanced or chat settings should appear. hope this helps.

View solution in original post

Reply
Loading...
Highlighted
Astronaut

Re: Re: Samsung Messages

JUMP TO SOLUTION
so I did that exactly how you said and it didn't change anything in the samsung messages app. I bought the phone from Samsung unlocked and put my Verizon sim card into it. do you think that has anything to do with another setting that may need to be changed? all of the RCS options were not previously enabled when I just went through it
Reply
Loading...
Highlighted

Re: Re: Samsung Messages

JUMP TO SOLUTION

you can upload your problem on Samsung Members app.
send/receive text message then go to samsung members app and upload your issue.


technicians will look into your log and see what the issue is.

Reply
Loading...
Highlighted
Cosmic Ray

Re: Re: Samsung Messages

JUMP TO SOLUTION
excellent so it did finally work. you can switch the phone app back to the Samsung one and settings should remain. just keep the phone by Google in case something weird happens. oh and I got this info from @sakitech from his YouTube channel.
Reply
Loading...
Highlighted
Cosmic Ray

Re: Samsung Messages

JUMP TO SOLUTION
were you always using Verizon? I believe all cell companies should have rcs enabled all already. hmmmmm..... have you tried restarting the phone. also Google messages should connect to chat as well.
Reply
Loading...
Highlighted
Cosmic Ray

Re: Samsung Messages

JUMP TO SOLUTION
oh and just double check that the settings are still enabled in the phone by Google after you restart.
Reply
Loading...
Highlighted
Astronaut

Re: Samsung Messages

JUMP TO SOLUTION
ok I will check. I did try restarting but I am still only getting the "settings-> more settings-> text messages -> show when delivered"
Reply
Loading...
Highlighted
Astronaut

Re: Samsung Messages

JUMP TO SOLUTION
you need to disable chat features on the old device before enabling on the new one. if you didn't, you'll be stuck waiting up to two weeks for it properly kick on.
Reply
Loading...