JUMP TO SOLUTION Solved

Original topic:

Galaxy A52 5G 5GHz Wi-Fi network connectivity problem!

(Topic created: 06-24-2021 01:11 AM)
adnan98
Asteroid
Options
Other Mobile Devices

I have a Galaxy A52 5G, no matter what I try to do it never connects to the 5GHz Wi-Fi network at my house. It connects to the 2.4GHz Wi-Fi network with no issues. I tried resetting the network settings, resetting the router, I even reset my phone to factory settings once yet the problem still persists. My almost 3 years old Huawei P30 Lite phone and my 4 years old Galaxy Note 8 phone have no connectivity issues with the 5GHz Wi-Fi network. It's a brand new phone, I do not understand how this could be happening. Can anyone assist me in solving this issue?

1 Solution


Accepted Solutions
Solution
raoulduke
Astronaut
Options
Other Mobile Devices
I used channel 40 but I would recommend trying a couple out and see what one gives you the best signal.

View solution in context

5 Replies
Lrock
Comet
Options
Other Mobile Devices
try changing the 5 ghz channel the router is broadcasting on, to something like 36 or 52
0 Likes
Reply
Who_Dis
Neutron Star
Options
Other Mobile Devices

just noting... 5ghz is very easily disturbed by obstacles between the phone and the router. so if you are not in a clear sight (or almost clear) of the router it'll significantly drop the signal strength and resolve to 2.4ghz.

that being said if you haven't checked already, check that you are or aren't able to get 5ghz connection near the router (also the router should be in an open space as much as possible, not in a corner somewhere). 

if you are able to get 5Ghz connection near the router, then you probably have weak connection elsewhere in your place and could benefit from signal extender/booster. 

Also, if you feel like the phone's wifi antennae is underperforming, try having it diagnosed by UBreakIFix repaircenter.

Or submit an error report using Samsung Members app after trying to get 5Ghz connection in different areas of your place

0 Likes
Reply
raoulduke
Astronaut
Options
Other Mobile Devices
I had the same problem when I first got my phone. I had to change the channel the 5 ghz was broadcasting on. My router was set to automatically choose the best channel but I changed it to one of the other channels and it connected.
0 Likes
Reply
adnan98
Asteroid
Options
Other Mobile Devices

Which channel worked for you? 

0 Likes
Reply
Solution
raoulduke
Astronaut
Options
Other Mobile Devices
I used channel 40 but I would recommend trying a couple out and see what one gives you the best signal.