JUMP TO SOLUTION Solved

Original topic:

I need android 7.0 to use my mobile banking app on my J7

(Topic created: 11-28-2020 08:46 AM)
Eagl1021
Astronaut
Options
Other Mobile Devices

I have Galaxy J7 Sky Pro running Android 6.0.1. I need Android 7.0 to use my mobile banking app.  How do I get it?

0 Likes
Reply

1 Solution


Accepted Solutions
Solution
Options
Other Mobile Devices
That phone is a little old and probably won't be updated so most likely you need a newer phone

View solution in context

3 Replies
Solution
Options
Other Mobile Devices
That phone is a little old and probably won't be updated so most likely you need a newer phone

View solution in context

Eagl1021
Astronaut
Options
Other Mobile Devices
That's sad. I like my phone.
0 Likes
Reply
Options
Other Mobile Devices
yea sad samsung only supports thr older phones for 2 years at least they chaged their policy to 3 years.
If your not in for software updates I recommend the Galaxy S9 or Note and maybe the S10e they cost much less now
0 Likes
Reply