cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Constellation

Lock-screen not responding, except when charging phone

I am using a Samsung Galazy Prime and in the past few days I have been experiencing the following problem on the lock-screen:

 

The lock-screen is not recognising any swiping (so that I can enter my pattern) unless I am charging the phone. While the phone is charging (from the mains, or from USB pluged into my PC) the touchscreen works exactly as expected, 100% of the time. When the phone is not charging, the lock-screen doesn't recognise my touches; I have to turn the lock-screen on and off a few times before it eventually recognises touches. Once unlocked it works perfectly.

 

As I type this message I have also tried ringing the mobile: when not charging the "swipe to answer" doesn't work; when charging the "swipe to answer" does work.

 

I have tried a factory reset but this did not resolve the problem.

 

I am inclined to believe that the problem is with the battery, since the problem doesn't occur while it is charging. The battery is a few years old now and doesn't hold its charge as well as it did when it was new.

 

I am tempted to buy a new battery but before I do I wanted to know if anyone else had any other suggestions?