Original topic:

Samsung Calendar won't sync with Google calendars

(Topic created: 11-12-2021 11:19 AM)
Jennysensei
Asteroid
Options
Other Mobile Devices

I removed two gmail accounts from my Samsung S9.  I then noticed all the events associated with those gmail acccounts disappeared from my Samsung calendar.  Oops!  To get those events back, I added those two gmail accounts back to my phone, but their calendars will not show up to the Sumsung calendar app.   

I have tried:

-clearing the cache and data from the Samsung calendar app

-downloading Google calendar to see if my calendars would sync and they do

-removing all email accounts from my phone and re-adding them.  Now NO calendars show up on the Samsung calendar.

I am able to access my email, calendars, and sync everything just fine on my computer and the Google calendar app.  Everything seems to be working except the Samsung calendar. 

5 Replies
LongHiker
Samsung Care Ambassador
Options
Other Mobile Devices

@Jennysensei Try this:

  1. Open the Samsung Calendar app
  2. Click on the 3 line menu in upper left
  3. Scroll down and you should see each of your accounts listed.
  4. Click the down arrow to the right of your Google account.
  5. You will see a list of all the calendars available for that account.
  6. Enable the calendar(s) that you want to see on the Samsung Calendar. 
  7. Repeat steps 4-6 for each account you want to enable the calendar. 
0 Likes
Jennysensei
Asteroid
Options
Other Mobile Devices

None of my accounts are listed in the Samsung calendar app.  I don't know why that is happening.  

0 Likes
Jennysensei
Asteroid
Options
Other Mobile Devices

None of my Google accounts are showing up in the Samsung calendar app.  

0 Likes
MrJell_Lee
Supernova
Options
Other Mobile Devices

please update if LongHiker's guidance helped fix the issue 🙂

0 Likes
Jennysensei
Asteroid
Options
Other Mobile Devices

The guidance did not fix the issue.  My Samsung calendar does not register any of the Google accounts on my phone.  

0 Likes