cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Oreofudge
Asteroid

WhatsApp Notification Issues

JUMP TO SOLUTION

After latest updates (Oreo?), I'm unable to stop notifications from WhatsApp to show up on screen as they come in.

 

All settings in WU are set to... TONE: SILENT: VIBRATE: OFF; NO POPUP... this is how I had them before and did the trick.

 

Settings in phone for this particular app are set to OFF, and only APP ICON BADGES is ON, yet messages still show up on screen.

 

I don't want to block it, I need to know I have a message there, but I should be able to silence them like before

 

Somehow the settings I set get reverted, any ideas?

 

Thanks!

 

 

1 SOLUTION

Accepted Solutions
Supernova

Re: WhatsApp Notification Issues

JUMP TO SOLUTION

That is rather strange, @Oreofudge. Sadly, if this is the only app that you are seeing this behavior in, you will need to continue to work with this developer.

 

If you need help with anything else, please let us know and our community will be happy to help!

 

Has anyone else seen this difficulty with Whatsapp?


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.


Reply
Loading...
7 REPLIES 7

Re: WhatsApp Notification Issues

JUMP TO SOLUTION

Hey @Oreofudge

I would recommend reaching out to the app developers to see if there were any changes to the app recently if you have not yet.

Reply
Loading...
Oreofudge
Asteroid

Re: WhatsApp Notification Issues

JUMP TO SOLUTION

Thanks for the tip.

 

I did reach out to them as well, and they replied with instructions, which are the same that I've been following and the issue persists.

 

I uninstalled it and then reinstalled it, and the issue persists.

 

I'm able to disable all notifications, but they get activated almost immediately, it's frustrating because it used to work, and almost certain before the OS upgrade.

 

Adolfo .-

Reply
Loading...
Supernova

Re: WhatsApp Notification Issues

JUMP TO SOLUTION

That is rather strange, @Oreofudge. Sadly, if this is the only app that you are seeing this behavior in, you will need to continue to work with this developer.

 

If you need help with anything else, please let us know and our community will be happy to help!

 

Has anyone else seen this difficulty with Whatsapp?


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.


Reply
Loading...
Oreofudge
Asteroid

Re: WhatsApp Notification Issues

JUMP TO SOLUTION

Finally the people at Whatsapp got back with a thorough explanation about the differences from "Popup notifications", which can be controlled within the app's settings, and "Peeking notifications" (the one giving me a headache), which can be controlled within the phone's settings.

 

I also learned that for now, under Android 8, you can only set the Importance to either URGENT or HIGH, reason why when using a different option it did not behave as supposed to. Once you set it to either of those two, you are able to control if you want these notifications to have a sound or not. And from what I'm seeing now, it's working.

 

Hope this helps someone else as well.

Reply
Loading...
userrsrRhbOBb0
Astronaut

Re: WhatsApp Notification Issues

JUMP TO SOLUTION

I have been facing the same issue myself and its really frustrating. No matter how many times I change this in settings it gets back to showing all vontent on locked screen and resets the notification to default.

Reply
Loading...
Oreofudge
Asteroid

Re: WhatsApp Notification Issues

JUMP TO SOLUTION

You must set Peek Notifications for WU to either URGENT or HIGH, then make all adjustments as to SILENCE and HIDE those notifications you do not want popping up. It is not a WU issue, so they came with this workaround, it has to do with how Samsung treats some notifications. Good Luck.

Reply
Loading...
useriDXUAH3nJM
Constellation

Re: WhatsApp Notification Issues

JUMP TO SOLUTION

I will recommend gb whatsapp over stock whatsapp as you can get many additional features !

Reply
Loading...