Original topic:

Help! QN90A Picture Clarity settings -- ready to return this TV

(Topic created: 11-19-2021 08:56 AM)
QLED and The Frame

When it comes to explaining what the various settings and options are in MANY of the Picture & Sound setups in the Menu, the most difficult to understand is Picture Clarity Settings for Blur Reduction and for Juddering.

I usually use the Movie or Filmmaker Modes. Blur Reduction can be anywhere from 0-20; Judder from 0-10.

But no where -- in the E-manual or even through Samsung Customer Support or from their replies the various communities -- does it explain which numbers reduce blur and judder?  To reduce both (to basically make my movies at 24fps at smooth as posssible),  so I move my arrow up toward the highest number, or set one or both to Zero ?

Every time someone asks Samsung this question ("i.e., how to reduce judder") the response is always a direct quote from the E-manual.  Nothing more.

So before I return this $1300 TV to amazon (because I just can't watch a single movie or streaming movie without this juddering), can someone out there tell me in Simple Words how to get rid of these two irritations once and for all?

Bonus points ifyou can tell me what Adjustments I should make for ALL the options under Picture Settings Clarity!  (LOL)   (This is from someone who used to be able to setup all his TVs, Receivers,  Apple TVs, and satellite connections with no  issues -- hey, 7 years ago, Things Just Worked ! )

I never had this issue with my previous Samsung TV from 2014.  But now with all these bells and whistles and 4K HDR and SDR and audio options that weren't around 7 years ago (making my $1000 Onyko receiver useless and my 7.1 Sony large-speaker sound system useless), this is just (sorry) over-kill.

I'm not a gamer, I'm not a sports fan. I just want to watch my DVDs and Blu-Rays and my black-and-white classic movies at the frame rate they were filmed at.

1 Reply
QLED and The Frame

If you're watching your movies via a computer (not a Blu-ray/DVD player) then adjust your Monitors preferences from 1080p 60Hz to 1080p 24Hz. That solved everything for me. Of course, it sucks that the Samsung TV can't properly handle 60Hz but that's a different story.