Original topic:

(QN90A) HDR not working with Game Mode on (Windows 10/AMD)

(Topic created: 12-09-2021 09:07 PM)
Ombrenoirz
Constellation
Options
QLED and The Frame

Need help about HDR not working when game mode is on. Even if VRR is turned off.

My graphic card is a Sapphire Vega 64 Nitro+ which has HDMI 2.0b ports.

To keep it simple, here's the things I did:

  • Certified HDMI 2.1 Cable
  • Windows HDR Turned On
  • Input Signal Plus Activated
  • Resolution 3840 x 2160 @ 60Hz (Because 2.0b limited to this)
  • YcBcR 4:2:2 12bit in AMD Settings
  • 10bit Option Enable in Graphism Settings in AMD Settings
  • VRR Enable
  • TV Firmware Updated
  • AMD Drivers Updated
  • Windows 10 Updates Done

After all this, everytime I put Game Mode on, VRR is FreeSync Premium Pro and HDR is always Off. Why is it like that ? My TV, my GPU, my cable supports HDR. Is it Windows because all HDR options are activated. I'm not sure its a brandwidth problem because even if I test 1080p with 30Hz, its still the same problem, VRR On HDR Off. HDR works only if I disable Game Mode, but the latency is horrible...

This is really driving me crazy, I really want to make it works. Game Mode is really nice and I want to keep it. Thank you in advance.

3 Replies
userKjGtjtyQ2B
Constellation
Options
QLED and The Frame

Hi Ombrenoirz, I'm experiencing something similar with my RX5700 (also 2.0b, and using 2.1 certified optical cable) -- I can only get the TV to recognize HDR signal when I use an HDMI input other than 4 / Game Mode is off. I'm new to HDR and still learning and trying different combos of settings. I'll post if I get something working! 

0 Likes
Ombrenoirz
Constellation
Options
QLED and The Frame

Use hdmi 4 port, dont forget to activate input signal plus. Game mode is the best ro play. It reduces input lag. I found a trick how to make it worth but i dont know if its the tv or pc that has the problem. Heres what i posted in another forum:

I found out what was the issue. I think there was a problem with resolution of entry versus desktop resolution. On newer games, i prefer to play 1080p 60fps, so i set my ingame resolution at 1920x1080, on forza horizon 5. In order to make hdr + vrr work in game mode i need to either set ingame res to 4k or down my desktop res to 1080p. Maybe its just the game. Because i tested nfs heat, hdr wont work in both ways. I found this game has some issues with hdr. Tested Mk11 and it worked fine.

0 Likes
userA8SfEfBwyT
Astronaut
Options
QLED and The Frame

After about an hour of trying different options I got it to work by plugging the HDMI into the fourth port (the one with the gamepad). I then put the TV in gaming mode and suddenly the option for 10 bit HDR was available on my PC (win11) with 4k at 120 hz!

0 Likes