cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Constellation

Can't use EX-Link with QN75Q70RAFXZA TV

JUMP TO SOLUTION

I'm trying to use the EX-Link connection on my Samsung QN7570RAFXZA TV.  I can successfully send a power-on sequence, but the TV doesn't respond to any other commands over the EX-Link connection (power off, set source to TV, set source to HDMI1, etc.).  Details appear below.  Can anyone tell me what I'm doing wrong?

 

Connectivity: 9600 baud, 8 bit, no parity, 1 stop bit, no hardware flow control

Configuration:

  Service Mode settings: 

    RS-232 Jack: UART

    EXT Link Support: ON

    USB Serial: ON

  Hotel/Hospitality Mode:  Hospitality mode on or off makes no difference

 

Power-On command sequence: 0x08 0x22 0x00 0x00 0x00 0x02 0xd4

Power-Off command sequence: 0x08 0x22 0x00 0x00 0x00 0x01 0xd5

 

I also set RS-232 Jack to DEBUG, and received lots of console traffic at 115200 baud (normal for debug mode, but not normal "ON" mode), but it didn't respond to anything I tried to type.  This tells me that my connection is good, at least for traffic *from* the TV.

 

1 SOLUTION

Accepted Solutions
Highlighted
Constellation

Re: Can't use EX-Link with QN75Q70RAFXZA TV

JUMP TO SOLUTION

For anyone else experiencing the situation where EX-LINK only responds to Power-On, but ignores everything else, the key is to turn AnyNet+ off and Hotel Mode (aka Hospitality Mode) on. So the settings that finally worked for me were:

 

Service Mode settings:
--RS-232 Jack: UART
--EXT Link Support: ON
--USB Serial: ON
Hotel/Hospitality Mode: OFF
Standard settings:
--AnyNet+: OFF
EX-Link com port settings:
--9600 baud
--8 bit
--no parity
--1 stop bit
--no hardware flow control

View solution in original post

Reply
Loading...
1 REPLY 1
Highlighted
Constellation

Re: Can't use EX-Link with QN75Q70RAFXZA TV

JUMP TO SOLUTION

For anyone else experiencing the situation where EX-LINK only responds to Power-On, but ignores everything else, the key is to turn AnyNet+ off and Hotel Mode (aka Hospitality Mode) on. So the settings that finally worked for me were:

 

Service Mode settings:
--RS-232 Jack: UART
--EXT Link Support: ON
--USB Serial: ON
Hotel/Hospitality Mode: OFF
Standard settings:
--AnyNet+: OFF
EX-Link com port settings:
--9600 baud
--8 bit
--no parity
--1 stop bit
--no hardware flow control

View solution in original post

Reply
Loading...