JUMP TO SOLUTION Solved

Original topic:

Q90t screen dims whenever subtitles apear in HDR

(Topic created: 12-18-2020 01:11 PM)
userK7K9IavFYg
Asteroid
Options
Qled and Frame

I just got the q90t 65 few days ago and already regret it.

It appears that whenever I'm watching HDR content and subtitles appears the whole screen slightly dims down. 

The only way to avoid it is by setting Local Dimming to Low, which really sacrifices a lot of pop to the picture quality. 

 

How did Samsung allow this to happen on higher end TV that cost so much? This is really frustrating.

 

Are Samsung awares of the issue? Do Samsung intend to fix that on a firmware update?

 

1 Solution


Accepted Solutions
Solution
userK7K9IavFYg
Asteroid
Options
Qled and Frame

Hi,  I might have a true workaround!
I would be happy if you can check it on your side and let me know, before I go and and open a bottle of champagne 🙂
So I've switched from Movie to Standard mode and this brightness issue is no longer happening!
I applied all the image settings so it's look 100% the same to what I had in Movie but now I can set Local dimming to high or standard and I'm not experiencing anymore any change to the brightness with subtitles.
Please let me know if it works for you.

View solution in context

0 Likes
Reply
14 Replies
Options
Qled and Frame
can you provide more model information on your device?
0 Likes
Reply
userK7K9IavFYg
Asteroid
Options
Qled and Frame

Q90t 65 inch

Full model number is QE65Q90TATXSQ

0 Likes
Reply
Options
Qled and Frame
Maybe contrast enhancer is set to high and the screen is trying to compensate the brightness of the picture and the text? I really have no idea, but just a thought.
0 Likes
Reply
userK7K9IavFYg
Asteroid
Options
Qled and Frame

Thanks but no...Contrast Enhancer settings aren't related to this.  It's local dimming thing

0 Likes
Reply
Samsung_pirate
Constellation
Options
Qled and Frame

I also have the 75" Q90T and have the same issue, it's quite distracting. Whole screen dims when subtitles appear on screen. This is with local dimming set to standard or high. Contrast enchancer set to off. The only thing that helps is setting local dimming to low which as you mentioned already, takes away from the PQ. 

 

Now with FW 1460, the screen is super dim in HDR with local dimming set to low (ex. Mandalorian on Disney+). Have to set local dimming to high & contrast enhancer to high to get the picture to stay adequately bright. 

 

Seriously starting to regret getting this TV. 

0 Likes
Reply
userK7K9IavFYg
Asteroid
Options
Qled and Frame

Are you saying that updating to latest firmware made it even worse? Oh man..

0 Likes
Reply
userTGUoCFvx7m
Asteroid
Options
Qled and Frame

Same here. I have the 75Q95T. Problem exactly the same. For HDR content I MUST have dimming set to high and contrastenhancer to max. Even then I find the picture still too dark. And then the subtitles will dim the screen. Even after the latest update. Beginning to worry here Samsung! For a €4000 TV this shouldn't happen. 

0 Likes
Reply
userK7K9IavFYg
Asteroid
Options
Qled and Frame

@userTGUoCFvx7m 

Thanks but I dont think this is the same issue I have described. 

With my issue setting the local dimming to "low" is the only solution to stop the screen from lowering its brightness when there are subtitles. Contrast Enhancer  settings does not make a difference. 

 

0 Likes
Reply
userTGUoCFvx7m
Asteroid
Options
Qled and Frame

It's part of the same local dimming issues that these TVs have.

 

I too have to set the local dimming to low for the subtitles to be displayed correctly and not dim the  entire screen.

 

I can't do that however because then it won't display HDR content properly.

 

For now I have set it standard and choose (for) me the lesser of two evils.

 

They should fix this pretty soon!