Original topic:

QLED Q60T 75” TV unable to go through terms & conditions

(Topic created: 02-25-2021 06:08 AM)
userhwtZ3DwABV
Astronaut
Options
Qled and Frame

Hi, my husband and I just are trying to setup are new QLED Q60T TV but we are unable to get through the terms & condition. It says the server is under maintenance. Our wifi is totally fine. It’s working for our other devices.

We live in a US military base in japan so we bought this TV in one of the exchanges out here. We know that the products sold there come straight from the US so we thought it would still work, regardless of the different regions. Since we live inside a US base, our wifi IP address is US (i.e. we have American Netflix and not Japanese Netflix). Buuuuut it just wouldn’t download the terms & conditions. We don’t understand how it works for Netflix but not for this case lolll idkkk 

So we’ve tried several things from other people who have experienced the same thing:

1. Unplugged our TV and even turned off our power strip. One time without resetting the factory settings. Second time with the reset. 
2. Tried to follow up the steps I did previously in combination with the SmartThings app. First I did tried to do it right when you first setup... It didn’t work. Then after resetting again, I tried after the initial setup and nothing. 
3. I’ve tried using Surfshark VPN and still nothing. Tried for maybe 2 hrs
4. I’ve tried it the normal way again and again, out of ideas and out of desperation but nothing... 

My husband gave up after an hour while I’ve been at it for 5 hours straight. Please help! We really don’t wanna return the TV for its size and quality but if this doesn’t work, then all we have now is a dumb 75” tv 😢

 

0 Likes
1 Reply
userB93rWhw5rg
Constellation
Options
Qled and Frame

I also have the same exact scenario. Have tried 1,2,&4 as you provided and no luck.

Is someone able to Help? I loved the Tv when it worked!

 

 

0 Likes