JUMP TO SOLUTION Solved

Original topic:

Powerbot 7040 making awful noise with brush

(Topic created: 01-11-2019 10:58 AM)
userOnIQ2ddjd9
Constellation
Options
Smart Home Support

Hello,

 

I have a Samsung Powerbot R7040 VR1AM7040WG/AA. Recently the machine started making an awful grinding noise when trying to vacuum. I normally keep the brush pretty clean, but I decided to replace the roll brush. Still making the sound.

 

I took the unit apart and cleaned out all the dog hair on the inside. I also took apart the brush motor and cleaned it out, it was very full. 

 

When I run the unit with a roller brush, it makes an awful noise, I am not so certain the brush is even spinning. When I take the brush out, the noise is mostly gone. I did notice a flat spot on the brush belt - probably 2-3 teeth are no longer there.

 

Is it safe to assume that I burned out the brush motor? 

Can anyone provide me a p/n for the brush motor?

I found a 7010 brush motor on ebay for sale, and it looks to be the same as what I have. Are the 7010 and 7040 motors the same?

 

Thanks!

18 Replies
Solution
SamsungTam
Samsung Moderator
Samsung Moderator
Options
Smart Home Support

If you are looking for parts for your device, you can visit Samsungparts.com or you can call 1.800.627.4368.


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.

View solution in context

0 Likes
Reply
userSBeTxjvrde
Constellation
Options
Smart Home Support

Had the same problem. Could not find belt alone and it was impossible to fit. Found out brush  motor bearings gone and belt motor assembly is too expensive to make it worth repairing. The Achilles heel,of this product. I have a ten year old roomba that is still running with only minor part replacements which is freely available. Love the programming and cleaning and quietness on Samsung but they should fix this design flaw. They're still selling this product exactly the same as two years ago. Mine stopped working last yea,r and I still have the parts in a box too sad to throw it away and hoping I can fix it. Yet to buy a used brush motor is not recommended since they are a high wear item. The reason for the failure is that the brush bearing seizes up inexplicable and then destroys the belt and motor and thus the whole unit if it is out of warranty like in my case a few days out and they would not cover repair. 

useroq4sOBO4Fl
Constellation
Options
Smart Home Support

Yes the bearing on the brush is the problem & cause of any other broken parts. I had mine serviced under warranty 1st time but now they want $170 for me to send it to them to replace the brush.

This bearing is a lemon of a part. Not sealed enough or rated for this application. May even be heat related since in is inside that rubber boot.

There should be a recall on this & free replacements available.

usergNaI5Owt6S
Asteroid
Options
Smart Home Support

Mine has been making noises for about a month, I just noticed today that the brush is not spinning, took it apart and cleaned the brush motor and bearings but the problem continued. I found this belt and I will give it a try, I'll update after I receive it. https://www.ebay.com/itm/132644913821

 

0 Likes
Reply
usergNaI5Owt6S
Asteroid
Options
Smart Home Support

So, here is my experience, the band at ebay was slightly smaller, I thought the original band had expanded but the real issue was that the brush motor shaft had carved a hole towards the right, to where the brush is. I got creative and turned the motor 180 degrees so the shaft is aligned again, and everything works perfectly! Hope this helps somebody. And I hope Samsung fixes this because it's a very very poor design...

userChJIxPcPSI
Asteroid
Options
Smart Home Support

Mine just started doing the exact same thing this week brush seems to be fine. Seems to be something with the motor that drives a brush. Too bad she was a nice unit for about 2 and 1/2 years just had to replace the battery once

0 Likes
Reply
userBrKWchGSoL
Constellation
Options
Smart Home Support

@usergNaI5Owt6S 

Are you referring to the part in the below link?

http://www.samsungparts.com/Products/Parts_and_Accessories/PID-DJ97-02486B.aspx?model=SR1AM7040W9

 

Did you just flip the cylindrical piece?

 

I was also thinking the belt needed replacement and thats when I came across you post. Thank you.

0 Likes
Reply
usergNaI5Owt6S
Asteroid
Options
Smart Home Support

That's exactly right, take the clear cover out and remove the band (it's probably going to be covered by a black dust) if you can move the motor shaft left and right (it moves about 1mm or 1/25in, it might even click when you move it) then you have the same issue I had. Rotate the cylindrical piece so that the shaft can't move and that will make it work again. Hope that helps! 

0 Likes
Reply
userBrKWchGSoL
Constellation
Options
Smart Home Support

That is very helpful. When I opened it up yesterday, I did notice the motor shaft move slightly, but I didn't thnk much about it because I was more focussed on the belt.

Yes, it was covered in the black dust and a lot of hair coiled up on the motor shaft. I removed all of that and the noise has reduced greatly, but not completely gone.

 

I will try to find some time to do this over the weekend and update here. Thanks again.

 

0 Likes
Reply