JUMP TO SOLUTION Solved

Original topic:

Powerbot 7040 making awful noise with brush

(Topic created: 01-11-2019 10:23 AM)
userOnIQ2ddjd9
Constellation
Options
Smart Home Support

Hello,

 

I have a Samsung Powerbot R7040 VR1AM7040WG/AA. Recently the machine started making an awful grinding noise when trying to vacuum. I normally keep the brush pretty clean, but I decided to replace the roll brush. Still making the sound.

 

I took the unit apart and cleaned out all the dog hair on the inside. I also took apart the brush motor and cleaned it out, it was very full. 

 

When I run the unit with a roller brush, it makes an awful noise, I am not so certain the brush is even spinning. When I take the brush out, the noise is mostly gone. I did notice a flat spot on the brush belt - probably 2-3 teeth are no longer there.

 

Is it safe to assume that I burned out the brush motor? 

Can anyone provide me a p/n for the brush motor?

I found a 7010 brush motor on ebay for sale, and it looks to be the same as what I have. Are the 7010 and 7040 motors the same?

 

Thanks!

JUMP TO SOLUTION
18 Replies
userkzr9800OLS
Astronaut
Options
Smart Home Support

Having the same problem on our M703 model. Tried to rotate the motor, but then it does not fit because of the wiring connection sticking from the back side.

0 Likes
Reply
user8jbs8NqVIt
Constellation
Options
Smart Home Support

Thanks for this tip, I did the same thing and the vacuum worked fine for about a month, then started making noise again.  I'm going to try replacing the motor.  Looks like it will require a bit of soldering but nothing major.

0 Likes
Reply
userndZVWJc4GA
Constellation
Options
Smart Home Support

Did the belt fix your noise issue?  Thanks

0 Likes
Reply
usergNaI5Owt6S
Asteroid
Options
Smart Home Support

Don't waste your money or time with the belt, the problem is not the belt is the motor. Mine just failed again today, Error C01, meaning the motor has failed again. it generates too much friction and overheats because the shaft tilts.

Unless you see your belt has some teeth missing I wouldn't waste money replacing it. 

Lightwizard
Constellation
Options
Smart Home Support

Adding to this thread and a warning to others, I also have the Powerbot 7040.  It failed with this same symptom while under warranty, after using it only about 6.5 months, and then it failed again, JUST AFTER the 1 year warranty after getting fixed once already.  So, for me, this fails about every 6 months, clearly a design flaw of the unit. Samsung now wants $199 to repair this, half the coast of the original unit.  This is extremely poor on Samsung's part.  For such a DESIGN FLAW, they should correct the error with a redesigned part free of charge for the consumer misery and lost time dealing with their issue.  Very bad.

I plan to fix mine myself. I'm waiting to see what Samsung does with this issue as I've contested paying the $200 to fix what is very clearly a design flaw.  I'll report back.

0 Likes
Reply
Lightwizard
Constellation
Options
Smart Home Support

I do have happy news to report, Samsung Support is doing the right thing and is covering this fix by extending the warranty for this repair.  I'll see how the new part performs. Being optimistic, I'm hopeful that the engineering issue is corrected (they need a stronger bearing apparently as that's what fails).  IF it fails again in the same time period, I'll report back.  Hopefully Samsung can use this to improve future designs.

I do have to say that I have a lot of other Samsung technology, and nearly all of that has been flawless (my Samsung watch OLED display has an infection, but I have a replacement plan I'll execute on that to get the new Samsung Watch being announced August 5th).

0 Likes
Reply
user3OKiODQDgr
Astronaut
Options
Smart Home Support

It appears that I'm now having the same issue. How did you get samsung to cover the fix?

0 Likes
Reply
prjct92eh2
Cosmic Ray
Options
Smart Home Support

The R7040 is truly a bad device. I had mine for 3 years. Had to replace both drive motors, the battery, the brush every 6 months and finally gave up when the brush motor started making all kinds of racket. It also routinely would get itself stuck up a wall, not make it back to the dock and was blind as a bat when cleaning in the dark. Got a Roborock S4 about a month ago and love it.

0 Likes
Reply
user4HUC38r73a
Astronaut
Options
Smart Home Support

It appears my brush drive belt has broken (brush now spins freely; not connected to any drive device whatsoever).  Can someone point me to a repair manual/website that gives instructions on how to remove the drive motor>  I got the unit apart, but there is still a lot of electronics blocking access to the brush drive motor.

 

Thanks in advance.