Original topic:

Solution to Tablet stops sending texts using cellphone and "Call & text on other devices" feature.

(Topic created on: 5/17/21 8:46 AM)
Dan5678
Cosmic Ray
Options
Tablets

My Tablet is connected to my Cellphone using "Call & text on other devices". It will send and receive SMS text messages for a day or two. Then, when I send a message, it spins for a while and eventually gives the error: Couldn't send message.

I am using T-Mobile on my Wi-Fi only Galaxy Tab S7+ tablet connected to my Galaxy S20 FE 5G cellphone.

Note that this solution only applies to T-Mobile or other Cellular Carriers that support "Call & text on other devices". "Call & text on other devices" is not supported by AT&T or Verizon.

Previously, the only temporary fix I could find was to perform a "Reset network settings" on my S20 FE 5G cellphone. This is very inconvenient because I lose all Wi-Fi and Bluetooth connection information.  Also, the fix only lasted for a day or two.

I spent 3 months trying things suggested online or by Samsung Support that didn't work. (Clear cache and/or data on Call & text app and/or Messages app. Wipe cache partition. Turn Call & text off/on. Reboot. Etc.) The only solution that would have fixed the problem completely was a Factory Reset and I wasn't willing to do that.

The main problem is that the "Call & text on other devices" feature on a tablet doesn't show up in the list of Apps. So, you can't reinitialize it by Clear Cache, Clear Data, Disable, or Uninstall Updates. So, you need some other method to reinitialize it.

In the past, on the tablet, I have turned the "Call & text on other devices" feature off and on many times and it didn't help. However, a couple of weeks ago, I turned off the Messages button underneath the "Call & text on other devices" before turning off "Call & text on other devices". That seemed to cause the app on the tablet to reinitialize because for the first time, when I was turning everything back on, it gave me this message on the tablet: "To continue, Agree to the Privacy Notice".

This solved the problem permanently. I have been using it for 2 weeks now without any issues.

The full procedure I went through was:

  • Tablet > Settings > Advanced features > Call & text on other devices > Calls > Off
  • Tablet > Settings > Advanced features > Call & text on other devices > Messages > Off
  • Tablet > Settings > Advanced features > Call & text on other devices > Off
  • Cellphone > Settings > Advanced features > Call & text on other devices > hold down tablet name > Remove
  • Cellphone > Settings > Advanced features > Call & text on other devices > Off
  • Wait 10 seconds
  • Cellphone > Settings > Advanced features > Call & text on other devices > On
  • Tablet > Settings > Advanced features > Call & text on other devices > On
  • Click Agree on tablet for "To continue, Agree to the Privacy Notice".

 

3 Replies
PV2Omni
Astronaut
Options
Tablets
FYI - not available on Verizon, and AT&T
https://www.samsung.com/us/support/answer/ANS00083152/
0 Likes
Dan5678
Cosmic Ray
Options
Tablets

Thanks. I added that to my post.

PV2Omni
Astronaut
Options
Tablets
You're welcome!
0 Likes