cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

RCS in Google Messages app - fix

(Topic created: 09-30-2021 02:34 PM)
Options
Tips
Was unable to make this work consistently no matter what I did. 

Clearing data and cache on carrier services, clearing cache on Messages, uninstalling and reinstalling both of them, restarting, etc.

Joined the Carrier Services and Google Messages betas today in the Play store. After the updates downloaded, I cleared data and cache in Carrier Services, and cache in Messages, and RCS immediately started working. 
9 Replies
user_ams007
Samsung Care Ambassador
Options
Tips
I keep saying that to people who have issues with the RCS chat
Options
Tips
And it shows that Google is working things out and hopefully will roll the fixes into production soon.
0 Likes
user_ams007
Samsung Care Ambassador
Options
Tips
Also, make sure that Google Messages is not Restricted and set to run unrestricted in the app Screenshot_20210930-174539_Settings.jpg
0 Likes
bigbad614
Comet
Options
Tips
I feel dumb... Where is that setting located?
0 Likes
user_ams007
Samsung Care Ambassador
Options
Tips
Click on app information and it's located in the battery settings, some apps need to have this turned on
0 Likes
bigbad614
Comet
Options
Tips
Lol! Thanks. It was right in front of my face!

It was already set to unrestricted.

Thx
USBetaModerator
Beta Moderator
Options
Tips

Hello @user2ZDoGgPbFk  @user_ams007 ,

Thank you for your post. We appreciate your contribution to the Beta community.

Regards,
One UI Beta Team

Options
Tips
An update to this. Yesterday I discovered that I was unable to send messages. Tried to send to a standard SMS account and got a message could not be sent error.

Checked the RCs chat settings and it was back to connecting instead of connected.

Turned off RCS chat for a little bit and turn it back on a little later and it connected up and seems to be working again.

But definitely this is still not 100% reliable.
0 Likes
HockeyLovinGuy
Asteroid
Options
Tips
I figured it out. Go to Google Messages -> Settings -> Advanced -> Phone Number. Make sure it is not blank. Mine was and once I typed in my number it worked.
0 Likes