JUMP TO SOLUTION Solved

Original topic:

Optical Audio Output not Working since Firmware Update

(Topic created: 08-09-2022 06:37 PM)
4917 Views
userfh1hfEfKRP
Asteroid
Options
QLED and The Frame TVs

I have a 2020 Q90T connected to a pretty old A/V Reciever, a Yamaha RX-V620. I set it up over a year ago and have never had a single problem until yesterday. When I turned my TV on in the morning it told me the firmware had been updated to version 2303, and ever since then, no audio comes through the optical output. I have tried hard resets on both devices, as well as changing the optical cable out for a new one. The port still seems to be working, as when I plug the cable in, it searches for a device, then tells me it can't find one(The port on the receiver works when testing as well)

 

Anyone had anything similar happen, or any suggestions on what to try? I feel like I've looked at it from every possible angle but nothing seems to work.

1 Solution


Accepted Solutions
Solution
userfh1hfEfKRP
Asteroid
Options
QLED and The Frame TVs

Figured out the problem. For some reason the audio output channel I had been using on my receiver suddenly stopped outputting in PCM, and I hadn't noticed because there wasn't an obvious way to turn it on or off. My solution wound up being to wire it up to a different output channel, which for whatever reason had PCM turned on already, and the TV was then able to detect it. Still no idea how the setting got changed, but at least I have sound back again.

View solution in context

4 Replies
Options
QLED and The Frame TVs

My Yamaha AVR is about 6 years old (RX-V481) but I do get audio via optical when connecting to my '20 Frame that also just received the latest v2303 update. Not sure why you're not getting any audio, but I assume you've set your sound output to optical in the TV sound settings?

 

 

 

 

 

 

0 Likes
Reply
userfh1hfEfKRP
Asteroid
Options
QLED and The Frame TVs

Yeah, it defaults to the TV speakers, when I swap it to Optical it spins then says it couldn't find a device, which is funny because if I turn the TV off and back on it detects it and asks if I want to connect, then fails anyway.

I also read online that manually setting the audio format to PCM can fix some issues, however mine was already set that way when the issue started and setting it now doesn't change anything.

 

 

 

 

 

0 Likes
Reply
Options
QLED and The Frame TVs

If TV detects an AVR is connected to the TV via Optical, then it will try to auto detect the AVR's brand for controlling the AVR with the Samsung remote. And if it fails the detection, TV will then display a popup asking if you want to go through the setup steps manually to select the brand.

In your case, when TV says it can't find a device, it tells me that there is no physical connection/communication between the AVR and TV. It sounds like a possible issue with the optical cable or the optical port from either the TV side or the AVR side.

 

 

 

0 Likes
Reply
Solution
userfh1hfEfKRP
Asteroid
Options
QLED and The Frame TVs

Figured out the problem. For some reason the audio output channel I had been using on my receiver suddenly stopped outputting in PCM, and I hadn't noticed because there wasn't an obvious way to turn it on or off. My solution wound up being to wire it up to a different output channel, which for whatever reason had PCM turned on already, and the TV was then able to detect it. Still no idea how the setting got changed, but at least I have sound back again.