Original topic:

Camera Not Working

(Topic created: 10-01-2021 02:40 PM)
Options
Discussions
Installed the beta on day one of offering (whenever that was). Today, (a few weeks later) the front & rear cameras won't work. Totally black screen.  Cleared app cache & data. Still nothing.  Any suggestions?

Regards, 😎


0 Likes

1 Solution


Accepted Solutions
Solution
user751201tmO21
Honored Contributor
Options
Discussions
Thanks for the feedback and solution!

View solution in context

16 Replies
Pgastwirth
Asteroid
Options
Discussions
There is a reset camera app within the camera app settings. Maybe try that?
0 Likes
Options
Discussions
I tried as you suggested. Still no good. Thank you.
0 Likes
user751201tmO21
Honored Contributor
Options
Discussions
(It's been two weeks, not quite three).

So, for clarification, the Camera app has been working, but just recently, is not working?
If "yes", can you think of anything that has been changed just before the Camera app failed?

And just to be clear, are you stating that you tap on the Camera app icon and all you see is black screen?
0 Likes
Options
Discussions
The camera has been working fine until today. The camera app opens and I can see the buttons and settings icons. The screen where you usually can see what your camera is seeing is black. Basically the same as if you put tape over the lens. This is for both front & rear cameras. I can take a pic and vid but the result is also black.

There was one weird thing that I reported as an issue on beta day one. While on a phone call the camera app would close if I tried to get into the camera settings menu.
0 Likes
UrsusMagnum
Cosmic Ray
Options
Discussions
Try rebooting, if it persists send a bug report with logs
0 Likes
Options
Discussions
Rebooted and wiped cache partition. Still no good.
0 Likes
Ang3lvasqu3z
Asteroid
Options
Discussions
Does it work with other apps?
0 Likes
Options
Discussions
No
0 Likes
Options
Discussions
I ran Samsung Diagnostics and it reports the camera, facial recognition & screen proximity tests have failed. I submitted an error report with logs.

Thanks all. 😎
0 Likes