cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Google pay security issue

(Topic created: 10-20-2023 03:17 AM)
461 Views
Beta4eva
Constellation
Options
Discussions
I'm not sure if this is stated somewhere but Google pay is not a possibility due to missing security certificate. Also got security certificate error message traying to print from phone. 
0 Likes
Reply
6 Replies
Options
Discussions
Gpay has never worked in beta. This is mentioned in the warnings you get when you join the beta and it's mentioned constantly on these forums. Use Samsung Pay if you need contactless payments.
Beta4eva
Constellation
Options
Discussions
I was a Nexus/Pixel user for a long time. When I switched to Samsung one thing Inwas loking forward to was MST on Samsung pay, which was eliminated on the S21 family which was what I got. (Have a S22 Ultra now). Because of that I never saw the point of Samsung pay. But thanks for the tip.
notforhire
Honored Contributor
Options
Discussions

I used to be a Samsung Pay user. However, I have a few cards that I can only load on GPay...they will not load on Samsung Pay. As a result, I moved to GPay. Looking forward to the stable OS for this reason alone.

0 Likes
Reply
Chef31684
Red Giant
Options
Discussions
So many posts about this. And my comment is the same every time.

This is a known thing. GPay has never worked on Samsung Beta builds. If people would just read the ToS agreement and the warnings before downloading and installing the beta, we wouldn't have posts like this every week.

If you want to use contactless payment during the beta, you will need to use Samsung Pay
Options
Discussions
there are multiple posts and it even states it in the beta sign up that certain pay apps especially Google pay as it is not a certified software version will not work, some people have Samsung pay working some don't, it's hit or miss with betas, but the most important thing to think or realize is that if that is something you use daily you shouldn't be running beta software as it will not be compatible
Mike31925
Asteroid
Options
Discussions
Got the same error
0 Likes
Reply