Original topic:

How can I get rid of this "Upcoming event" that shows up on lock screen?

(Topic created: 02-29-2024 08:14 PM)
762 Views
WhatMeWorry
Astronaut
Options
Other Mobile Devices

Galaxy A15, Android 14. Phone not "locked"(or is it, per, se?) - I just double tap the blackened screen and swipe up. (That still means "locked" and "lock screen", right?) 

 
So from the black screen I get a sound and an aqua full screen saying "Upcoming event" from a Calendar event EVEN though I swiped off Settings/Notifications/Lock Screen Notifications at the top. GRRR. In fact, unless I swipe that Settings option to On, then select hide content, then turn it off again at the top, it will even show the event text, even though I've set lock screen notifications Off! NOT COOL.
 
And as a bonus it's very hard to get rid of. You push the dismiss button and nothing happens (I've now learned that you swipe the literal Dismiss button (capital X on my attached image) off the left of the right edge, extremely peculiar), or snooze it. You can't just ignore it and swipe into your phone as if it wasn't there.
 
So in my testing, it *seems* to only happen on something with an ALERT. Sure, I want to get a snoozable advance notification alert when the phone is in display mode, and I want it on my notifications stack, but NOT after I clicked the power key to blacken the display. I don't want to set my phone down on my desk, and then something comes up for the world to see like 
Upcoming event
Some private thing
Starts in 1 minute
 
I have not tested to see if a PIN arrangement changes this behavior. What an absolute unacceptable horror THAT would be, if I "locked" my phone "for real", set it down, and a calendar event started appearing, even though I have turned OFF lock screen notifications. 
 
Before I took all of your valuable time with all of this, I did futilely Google and Google for it. Does anyone even recognize this happening? Because it seems to be completely absent from Google. "Upcoming event" lighting up my blackened screen.
 
To reproduce, create an event 1 minute from now, click alert to add one for e. g. 10 minutes prior, save, push the power button to blacken your phone, and wait for that minute to arrive. It might even happen in a couple of seconds, rather than waiting for the actual minute to occur. 
 
image
10 Replies
realaud
Red Giant
Options
Other Mobile Devices
Go into you settings, choose lock screen, then choose the image to edit (lock screen and/or widgets. On the lock screen edit, remove the widget frame if it's there. Click done and then coose the other image to edit an then turn off the sliders for things you dont want to appear. On the privacy screen-like todays scedule, mext slarm, etc
0 Likes
harv134
Explorer
Options
Other Mobile Devices
Pls mark the answer if it worked
0 Likes
WhatMeWorry
Astronaut
Options
Other Mobile Devices
No, this is not something built into the screen, the image above appears only when an event is approaching. And it doesn't come from clicking the display clock, but rather so-to-speak "spontaneously" pops up telling me there's an upcoming event. But thanks for the thought
0 Likes
realaud
Red Giant
Options
Other Mobile Devices
You have to do what i said and turn off todays schedule
0 Likes
WhatMeWorry
Astronaut
Options
Other Mobile Devices
Thank you for your thoughtful advice. That wasn't it. I tried it anyway in consideration for your kind advice with no resolution unfortunately. However it did have a happy ending, after trying another tactic described later.
0 Likes
WhatMeWorry
Astronaut
Options
Other Mobile Devices
Did anyone reproduce this or even recognize having seen it? I left what I hoped were very quick and simple instructions by the image above.
0 Likes
KiwiBird97
Red Giant
Options
Other Mobile Devices
Are you using a medium or strong alert type for your calendar? If so, change it to light.Screenshot_20240229_233156_Calendar_1000022446_1709278316.png
WhatMeWorry
Astronaut
Options
Other Mobile Devices
(GROWL I had to retype this entire reply because it went "server error" and discarded it summarily. Used "Notes" this time as a precaution, grrr.) Outstanding. Now that's my kind of specific and correct response! Yes, I was at the [default] medium setting and changed it to light, which does prevent the visual atrocity, although the audio remains. Shrewd image choice by you, by the way.

I'm hesitant to mark this as "solved" because the lock screen setting should forbid even an audio invasion of the lock screen, and requiring the user to find the obscure setting as you somehow did shouldn't be necessary to resolve the built-in conflict on that nasty and potentially privacy-destroying visual.

Is there a facility to report this bug?

(We should also consider, from a scientifically precise technical point of view, is what I described at the beginning an according to Hoyle "lock screen", since it's just a finger swipe rather than PIN entry? That seems illogical but I'm just "dotting the i's and t's" before I scream "bug")
0 Likes
Options
Other Mobile Devices
This has nothing to do with the app notifications that you turned off. The event alerts are configured in your calendar app's settings.

Open your calendar app. Tap the three-lines menu in the upper left corner of the screen.

Tap the gear icon in the upper right corner of the screen.

Go down the page until you see "Default alert times". Tap on that.

Set the alerts however you want them. You can set all three to "no alert" if you want to.
1709328474896.jpg1709328474925.jpg1709328474956.jpg