JUMP TO SOLUTION Solved

Original topic:

Samsung 55 S95C HDMI-eARC problems

(Topic created: 03-19-2024 01:17 AM)
865 Views
FredMel
Constellation
Options
Projectors & Other TVs

Hi All,

I have a Samsung 55" S95C & have been using the HDMI e-ARC port to connect to my HiFi streamer/amp (Bluesound PowerNode 330).

The system worked well at first but recently I've found that the connection has dropped and reverted to the TV speakers. If I try to select the input manually it doesn't appear in the dropdown list (although HDMI Bluetooth does). I've been through the menus on both the TV and amp but nothing seemed to work, although the connection does sometimes reappear randomly. Have tried a new HDMI cable but the problem persists.
 
I subsequently discovered that if I enter the Samsung sounds menu, navigate to expert settings, scroll to HDMI-eARC mode, switch this from auto to off, then switch back to Auto the connection to the Bluesound amp works again, after hitting the volume button on my Samsung remote briefly. Not entirely satisfactory as I need to do this each time I switch the tv on, but at least I can get it to work now! A one else experienced this problem, or can offer advice? Thx
3 Replies
Wayfarerkk
Astronaut
Options
Projectors & Other TVs

I have the same tv and a Bluesound soundbar+ with sub and two flex as rears. After 38 minutes the connection to the rears and subs stops working.

0 Likes
Reply
oneone1995
Asteroid
Options
Projectors & Other TVs
0 Likes
Reply
Solution
FredMel
Constellation
Options
Projectors & Other TVs

Update. I switched off the ‘Auto’ setting in the sound - expert settings - HDMI-eARC mode section permanently. This appears to have cured the problem. My amp now appears as (amp name)HDMI and volume is controllable via Samsung or  my satellite receiver remote. Bit odd that system has problems with eARC but seems to have eARC functionality on HDMI but at least I’m happy that everything now works.