JUMP TO SOLUTION Solved

Original topic:

Smart Call not working on incoming calls after PIE update

(Topic created on: 2/19/19 3:31 PM)
The_Chemist
Cosmic Ray
Options
Galaxy S Phones

I hope someone can help with this frustrating issue.

 

My S9 Plus just received Android 9 Pie update today.  After the update my "Samsung Caller ID" Smart Call stopped displaying the name of any incoming caller not in contacts when the call comes in. 

 

Smart call still will display names of places or people called not in contacts on outgoing calls.  I don't get it!

 

Smart call is turned on in the phone settings. 

 

I found the app and allowed permissions to phone and contacts, but still not working.

 

I looked on my Note 9 as well and found the Smart Call app.  It does not have permissions granted for phone and contacts, but yet it works.  So, I don't think that is the problem.  Apparently PIE messed something up on my S9 Plus. 

 

Does anyone know how to fix this, or do we have to wait for an update?

 

Thanks in advance to all who reply.

JUMP TO SOLUTION
user0NEekad4LX
Asteroid
Options
Galaxy S Phones

I'm having the same problem!!!  And I'm on AT&T. This morning my phone upgraded 4 times!  Still the issue is not fixed!

0 Likes
Reply
user3uVlkT8nht
Astronaut
Options
Galaxy S Phones

It didn't work for me. Hope it gets resolved, so frustrating.

0 Likes
Reply
SamsungQue
Samsung Moderator
Samsung Moderator
Options
Galaxy S Phones

This is how you wipe the cache partition on your phone.

  1. Turn off the device.
  2. Press and hold the Volume Up key and the Bixby key, then press and hold the Power key.
  3. When the Android logo displays, release all three keys.
  4. An 'Installing system update' message will show for 30 - 60 seconds before the Android system recovery menu options appear.
  5. Press the Volume down key several times to highlight wipe cache partition.
  6. Press Power key to select.
  7. Press the Volume down key to highlight yes, them and press the Power key to select.
  8. When the wipe cache partition is complete, Reboot system now is highlighted.
  9. Press the Power key to restart the device.
0 Likes
Reply
userz1AYsCHNLq
Constellation
Options
Galaxy S Phones

Hello everyone. Go to -Settings, then -Network & internet, then tap under

-Wi-Fi your network,

then under -Mobile data -Roaming and -App data usage, tap -Advanced, tap -Preferred network type and select GSM/WCDMA/LTE. Works like a charm. Cheers. Choose Your cell phone operator name as well in -Mobile network -Advanced -Access Point Names.Smiley Very Happy

0 Likes
Reply
userz1AYsCHNLq
Constellation
Options
Galaxy S Phones

Hello everyone. Go -Settings -Network & internet, under -WiFi tap on your network,

under -Mobile data -Roaming -App data usage choose -Advanced tap -Preferred network

type and select GSM/WCDMA/LTE. Work like a charm. Cheers Smiley Very Happy

Choose Your cell phone operator name as well in -Mobile network -Advanced -Access Point Names.

0 Likes
Reply
ccalberti
Asteroid
Options
Galaxy S Phones

Thank you.  I had the same problem on my Note 9, and this solved the problem.

0 Likes
Reply
Quique_Schamann
Astronaut
Options
Galaxy S Phones

Additionaly to Clean Data & Cache of "Smart Call" application, I found the "Hiya Service" application and also cleaned its Data & Cache.

After clean both apps ("Smart Call" and "Hiya Service"), now is working fine

0 Likes
Reply
Clsisk3
Asteroid
Options
Galaxy S Phones

Is there a time frame on a fix for this??

I already accepted that there will no longer be personalized text ring tones and got another messaging app.. but now no caller ID because of the PIE update? This is ridiculous, too much money paid for a phone that isnt even working as a PHONE efficiently. I have six people in my family, we all have samsungs and 2 of us are having this issue. I am starting to doubt we will be doing samsung on our next round of upgrades. 

 

0 Likes
Reply
The_Chemist
Cosmic Ray
Options
Galaxy S Phones

@Clsisk3 wrote:

Is there a time frame on a fix for this??

I already accepted that there will no longer be personalized text ring tones and got another messaging app.. but now no caller ID because of the PIE update? This is ridiculous, too much money paid for a phone that isnt even working as a PHONE efficiently. I have six people in my family, we all have samsungs and 2 of us are having this issue. I am starting to doubt we will be doing samsung on our next round of upgrades. 

 


First of all, before there will be a fix, Samsung has to admit there is a problem.  At this point I don't think Samsung has admitted that a problem exists. They kerp blaming the lack of Smart Call on our carriers. 

 

Unfortunately for me, I allowed my Note 9 to upgrade to Pie.  Now that phone has the Smart Call not working issue as well. 

 

The main reason I bought Samsung phones was to get Smart Call. Now since Smart Call was broken by the Pie upgrade there would be no more incentive for me to own Samsung phones  

 

When I upgrade to new phones when 5G is up and running in my area, I will most likely purchase another brand of phone  I'll end up shelling out $3.00 a month to greedy Verizon for their caller id and sp@m filter service, so I may as well buy a feature packed phone from another manufacturer  

 

For me, the incentive to purchase Samsung was Smart Call.  Since Smart Call no longer works, the incentive is gone.  

 

Samsung, c'mon admit there is a problem and fix it in a timely manner. 

0 Likes
Reply
user0NEekad4LX
Asteroid
Options
Galaxy S Phones

This works!  

Go to Settings; Apps; Call Protect App and disable or force stop it

Found it on another thread.  I just disabled it and the calls now show

who is calling.