cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Astronaut

S3 frontier notifications stopped working

Good day, yesterday my Galaxy Frontier s3(Bluetooth version) watch suddenly stopped notifying me of most every thing my phone was doing.  I no longer get notifications from my text app (next sms), Gmail, Yahoo mail, Calendar (business calendar) from my Google Pixel 2 phone and probably some other apps like Instagram and others, but the test and mail apps for sure suddenly quit working.

 

I tried the ususal, reboot the watch, and the phone (3 times each) un-paired and re-paired the watch, and usually the last thing that fixes it (because this seems to happen every 6 months or so) I deleted and re-installed the Galaxy Wear application and re-set up the watch to the phone.  Nothing works.  I then tried to reset the watch to factory defaults (3 times no luck) and even tried setting up the watch on my second phone (SM-G975U) and that didn't work either.  The only notification I get is when the phone rings.  I also randomly get the icon showing the phone is disconnected from my watch, but if I call my self the watch rings and I can answer the phone, so its not really disconnected. 

 

I have loved this watch for over 2 years, and now its basically just a time telling device, and the whole reason I bought it, was so I could keep my personal phone in my pocket while at work, and still be able to read text and emails when needed.  I have tried different plug-ins as well, checked for updates to the phones firmware, and nothing is available, please help.