Original topic:

Cannot sign in to Samsung account on phone, but can sign in via web browser

(Topic created: 09-11-2021 09:24 AM)
Samsung Apps and Services

Dear Samsung forum community


After changing my password, I am unable to login to my Samsung account on my Galaxy phone (via the Samsung Account app), but am able to login on a web browser (both on my phone and my laptop). I am posting here to see if anyone else has prior experience with this, it is very frustrating.


Note: I am based in Australia, but am posting this on the USA forums since I'm guessing this has the most active users.



  • I have a Galaxy S10+ that was successfully logged in to my Samsung account. I have 2 factor authentication enabled on my account (SMS code, Authenticator App and also backup codes). 
  • 2 days ago, I decided to change my Samsung account password because I had not done so for several months.
  • After changing the password on my computer web browser, my phone sends a notification saying "you must sign in with your Samsung account password again".
  • I try to sign in with my new password (this is within the "Samsung Account" phone app, not the web browser on my phone). After I enter the password, I come to the "agree to the terms & conditions page". Once I click "agree", it says "Invalid user ID / password".
  • I try the same password, but this time I'm using my internet browser on my phone (Mozilla Firefox). It prompts me to enter 2FA code, and after I do that, I can sign in successfully. The same happens when I use the internet browser on my Windows 10 laptop.
  • What I find very odd on the Samsung Account Android app is, it initially accepts my password, only to reject me at the "terms and conditions agree" page. At no point does it request for a 2FA code.
  • So, now I am locked out of my Samsung account on my phone (I am still "partially" signed in because the account name is still there, but I can't use various features). For example, I cannot use Samsung Pay anymore, and I cannot update my Galaxy store apps because it prompts me to login before I can update them.
  • I tried this on a brand new S21 phone that I have never signed in to, and I have the same issue there.


Troubleshooting steps I have already taken


  • Checked that phone is on latest Android software update (both my S10+ and S21).
  • Checked that "Samsung Accounts" app is up to date (I am using v12.5.00.13 on the S10+).
  • Tried rolling back the "updates on "Samsung account" via "Settings > App > Uninstall updates".
  • Restarted phone
  • Cleared cache in "Samsung Accounts" app (it only lets me Clear Cache, the "Clear Data" button is greyed out) and "Samsung Galaxy Store" app.
  • Tried it on a brand new (literally straight out of the box) Galaxy S21 (this one has "Samsung Accounts" app v12.2.00.9). Also tried restarting the S21, it doesn't help.
  • (With both the S10+ and S21) I have tried logging into my Samsung account via the phone web browser, and then at the "2FA code" page, I tick the box "remember this device in the future". After I try again via the "Samsung account" app, it makes no difference (still says "Invalid user ID / password")
  • I have checked very carefully and I am not mistyping the password.
  • The password meets the requirements stated by Samsung: 8 to 10 characters, at least one symbol (only exclamation mark is allowed), one upper case, one lower case, one number.
  • Tried resetting the password multiple times.
  • Waited 24 hours after resetting the password to login again.
  • Tried on both mobile data and home WiFi.


Contacting Samsung support (Australia)


I called the Samsung account hotline. They asked me to try clearing the cache and reset the password, and failing which asked me to do a factory reset. I personally don't think a factory reset will do anything because I can't even login on a brand new S21 phone (that I've never used before), so I doubt a factory reset on my existing S10 will help. I asked if they could disable 2FA from the back end, to see if that was causing an issue, but they said they cannot disable 2FA.




I am very disappointed at this nightmare experience, all I wanted to do was change the password (which was actually recommended by Samsung as a pop-up message after logging into their website). The password is clearly functioning because I can use it to login via the web browser.


Can anyone shed some light on what may be happening here ? Would greatly appreciate this.


Thank you.

1 Reply
Honored Contributor
Samsung Apps and Services

I can understand how frustrating this whole issue can be. Being that you are based in Australia you will have to reach out to our Samsung Australian board for assistance. Here is a link to help find the correct board (https://www.samsung.com/visitcountry/)