JUMP TO SOLUTION Solved

Original topic:

S20 Ultra not receiving calls

(Topic created: 04-07-2020 08:06 PM)
138760 Views
userJmvrAskEUn
Asteroid
Options
Galaxy S Phones

Hi

I am really annoyed with this phone for the price.

Great for internet etc, but wont receive calls constantly have to restart it, then its fine for 10 mins and drops again. I am with Spark NZ definitely no account problem and others in my house have no issues. SIM works fine in my S9.

Who wants to turn their phone on and off every 15 mins? Callers either get a message saying call person you called cant be reached, or it goes to voicemail. Samsung you need to do a bug fix for this !!. Seems to be a common problem across many carriers

JUMP TO SOLUTION
79 Replies
user8jJpRZIhcS
Asteroid
Options
Galaxy S Phones

Hi there, 

 

I am holding S20 Ultra on Skinny (Spark) NZ network, and last week I had the similar issue with you guys. When it connects to home WiFi, it cannot receive any calls/txts. After disconnect WiFi, it works like normal. Only happen two / three times in total. 

Here are my findings:

Device with 2degree SIM card = no issue;

Device without WiFi = no issue;

Device connect to WiFi but just made phone call/txt = no issue;

Skinny SIM card in iPhone = no issue;

Device with Skinny + WiFi on + not making call/txt for a while = issue!

 

Anyone has similiar finding or just my device doing this? 

 

Anonymous
Not applicable
Options
Galaxy S Phones

Hmm... cheers for the intel! Yeah, I can say something similar (seems to be tied to the WiFi). Wondering if the latest update in NZ (ATE6) released recently maybe has changed anything? I've gone back to my old phone for now, so I have my S20 Ultra just sitting idle at the moment.

0 Likes
Reply
user8jJpRZIhcS
Asteroid
Options
Galaxy S Phones

I have updated it to ATE6 on this Tuesday, currently no issue found yet (mainly because less phone call recently). Will keep checking to see it gets fixed or not. But, based on others' find, it might not solved yet. 

0 Likes
Reply
userEL3SX4nt3g
Asteroid
Options
Galaxy S Phones

I have the exact same issue with my Samsung Galaxy S20 Ultra 5G. Many customers can not reach me sometimes. I'm on ATE6 FW, central Europe. I have two SIMs and primary is T-Mobile. It's serious problem!

 

0 Likes
Reply
userRZh68O1sip
Constellation
Options
Galaxy S Phones

I have the same problem.  My phone is from Mexico with carrier telcel. I just got the ate6 update and making tests.

0 Likes
Reply
user8jJpRZIhcS
Asteroid
Options
Galaxy S Phones

any fault replicated after software update? Mine seems OK but not sure yet. 

0 Likes
Reply
userNN3h0YNH7z
Asteroid
Options
Galaxy S Phones

So I noticed that the issue was gone for me ever since I updated to ATE6 build on 3rd June 2020.

However, just now I just realized that my network settings were changed to 5G/LTE/3G/2G automatically by the update.

I have just switched back to LTE/3G/2G to see if it persists again, as this is the mode that I have always been using my S20 Ultra in, and because 5G is not launched yet in Singapore.

If the issue comes back, then changing network settings to 5G/LTE/3G/2G may be a temporary fix for this issue, perhaps at the expense of slightly shorter battery life.

0 Likes
Reply
Solution
CORTANA
Asteroid
Options
Galaxy S Phones

Here are some troubleshooting steps you can try to get the phone working again for those calls. https://www.samsung.com/us/support/troubleshooting/TSG01001613/  If the troubleshooting is not helpful, you will need to follow up with your service provider for additional troubleshooting steps.

userFhFnSn5vwd
Constellation
Options
Galaxy S Phones

My phone: S20 Plus (512 gb)

Country: Australia, Optus network

 

I found a solution for this annoying problem caused by Samsung's poor cutomer support!! Please, let me know if it also works for you:

 

1- Go to Setting

2- Connections

3- Wifi --> Advanced

4- Disable "Switch to mobile date"

5- Connections

6- Diasble "Wifi Calling"

 

 

0 Likes
Reply
kkwills
Astronaut
Options
Galaxy S Phones
did this end up working for you. it didn't help me