cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Constellation

Wifi keeps turning on automatically after I turn it off

JUMP TO SOLUTION

Hello, I have Samsung S7 Edge on T-mobile network.  For the last week i been having issue with my wifi, I turn it off and after like 5 minutes it turns on by itself. I tried to look up the issue, but i can't find anyone reported it before.  Most of them are wifi is disconnecting.  Can someone please help ? 

 

Thank you.

1 SOLUTION

Accepted Solutions
Highlighted
Constellation

Re: Wifi keeps turning on automatically after I turn it off

JUMP TO SOLUTION

I was able to resolve it by going  into my location settings and disable scanning wifi to improve accuracy, hope this helps

View solution in original post

Reply
Loading...
34 REPLIES 34
Highlighted
Neutron Star

Re: Wifi keeps turning on automatically after I turn it off

JUMP TO SOLUTION

two possible causes. 

T-Mobile may have an app on the phone that does WiFi Managment. (it did on my old S4). Disable the app. 

There is a Smart WiFi setting in the phone setting. Disable that too. 



Superman on Galaxy S7 SM-G930T, T-Mobile, Baseband:G930TUVY3APIA
To OP: click "✓ Accept as Solution" when you find an answer that works for you.

Reply
Loading...
Highlighted
Constellation

Re: Wifi keeps turning on automatically after I turn it off

JUMP TO SOLUTION

Actually it was the xfinity wifi app that I installed and it had automatically connect to best network,so I turned that off and it resolved the issue.  

 

Thank you. 

Reply
Loading...
Highlighted
Neutron Star

Re: Wifi keeps turning on automatically after I turn it off

JUMP TO SOLUTION

@assyrian572 Glad you could fix it. 

 



Superman on Galaxy S7 SM-G930T, T-Mobile, Baseband:G930TUVY3APIA
To OP: click "✓ Accept as Solution" when you find an answer that works for you.

Reply
Loading...
Highlighted
Astronaut

Re: Wifi keeps turning on automatically after I turn it off

JUMP TO SOLUTION

Finally found it on the S8 plus how to turn off it automatically turning wifi on.  Go to settings, click connections, then click locations, then click improve accuracy, then disable wifi scanning. 

Reply
Loading...
Highlighted
Constellation

Re: Wifi keeps turning on automatically after I turn it off

JUMP TO SOLUTION

This is the only solution that has helped me. I have a Galaxy Note 8.

Reply
Loading...
Highlighted
Constellation

Re: Wifi keeps turning on automatically after I turn it off

JUMP TO SOLUTION

I even knew that answer. Read all App funtions and customer feedback before you install Apps even in Ap store they should tell you what to expect.

Reply
Loading...
Highlighted
Constellation

Re: Wifi keeps turning on automatically after I turn it off

JUMP TO SOLUTION

Hi, I have an unlocked international s7 edge and my WiFi keeps turning on and off continously. I need it to stop doing that. I do not have any xfinity or any service providers apps.

Reply
Loading...
Highlighted
Black Hole

Re: Wifi keeps turning on automatically after I turn it off

JUMP TO SOLUTION

Hey there, @aasheesh

 

if you have attempted all other troubleshooting steps provided, please attempt to go into your settings and go to Location. Here you will go to accuracy and choose to disable WiFi scanning. If you are still experiencing problems, let the Community know what steps you have taken already to try and resolve this. 

Reply
Loading...
Highlighted
Astronaut

Re: Wifi keeps turning on automatically after I turn it off

JUMP TO SOLUTION

I have come across the procedure as you said but even after wifi scanning in location is disebled 

The same problem of turning on of wi fi automatically has arisen

Hope that anyone will solution for the same 

Thank you

Reply
Loading...