Original topic:

Galaxy Tab S9 Ultra problems with Wifi 6

(Topic created: 12-06-2023 05:21 PM)
7740 Views
forestation
Asteroid
Options
Tablets

Bought a Galaxy Tab s9 Ultra last week and have had issues with Wifi 6.

The tablet would establish a connection with my Wifi 6 router, but then every few minutes (sometimes even more often) the browser will time out when loading a page and the tablet settings will show "Connected without internet" next to the Wifi connection.

I've tried resetting the tablet's network settings and also powering cycling my router, and the problem has persisted. Other people online have reported the same or similar problems, but I wanted to clarify based on my own experience:

1. The problem is occurring with my Wifi 6 router. (Some have speculated the issue may be related to Wifi 6E.)

2. The problem seems to only occur when the Wifi signal is moderate or weak.  More specifically, the problem occurs when my tablet is in the next room from the router (~30 ft. away), but not when it's in the same room (~10 ft. away).

3. I have a Tab S7+ and the Wifi works normally when connected to the same router.

4. Changing from randomized MAC Address to fixed MAC address didn't help.

5. Changing the Wifi encryption from WPA2/WPA3 to WPA3 or WPA2 didn't help.

Can we get Samsung to officially acknowledge the issue and give an ETA for resolution?

23 Replies
OoYORIoO
Sun
Options
Tablets
@forestation

Welcome to the Samsung Member's Community and thank you for your question regarding your Samsung Galaxy Tab S9.

Please try setting your IP Adress to "Static IP" See of this works first.

Here are a few other steps you can so to see if one of these fixes the issue. Thank you for being descriptive with the troubleshooting steps you've taken so far. I know some of them you have tried. Thank you!

So here you are!

1. Turn Off Medium Power Saving Mode
2. Select "Optimized Power Mode"
3. Disable Wi-Fi Power Saving Mode
4. Disable Wi-Fi Power Saving Mode
5. Navigate to Settings
6. Tap on Connections.
7. Tap on WiFi.
8. Tap Advanced & Toggle "Wi-Fi power saving mode to OFF
9. Toggle Airplane Mode
10. Look for Airplane Mode in the notifications area
11. Tap on the icon to enable the mode
12. Leave it on for a couple of seconds
13. Tap on the icon again to disable it

***Forget All WiFi Networks:***

A helpful method in solving WiFi problems is to delete all networks so that your phone's WiFi gets a fresh start.

1. Go to the Settings menu of your phone.
2. Tap on Connections.

Look for WiFi and tap on it.

All WiFi networks that you have added to your phone will be listed here. Tap on each of the network names and tap on Forget

***Reset Network Settings:***

If your Samsung Galaxy Phone's Wifi won't turn on, one solution is to Reset network settings. Here is how:

Navigate to Settings
Tap General Management.
Now tap on Reset.
Tap Reset network settings.
Confirm the action.
Your device will reboot.

***Change Date and Time***

The date and time on your device must match the date and time on the router that you are trying to connect to, or else you may not be able to establish a connection.

Navigate to your phone's Settings menu
Tap on General Management
Find the Date and Time and tap on it.
Tap on the option to set the time automatically.

***Smart Network Switch***

Some Samsung Galaxy phones come with the Smart Network Switch feature. This feature switches between your WiFi and cellular networks if there is an unstable connection. To switch it Off: Navigate to Settings, Tap on Connections, Tap on WiFi.

Tap on the three dots in the upper right corner.
Tap Advanced.
Check the Auto network switch option to disable it.

***Third-Party App: Enter Safe Mode: ***

Some third-party applications can cause a conflict with your WiFi network. To troubleshoot this issue, you can switch your phone to Safe Mode. Once you do that, third-party apps will be disabled.

Press and hold the Power button on your device until you see the Power menu > Tap Power Off
Press and hold the Power and Volume Down buttons at the same time to turn the device on.
Once the Samsung logo appears on the screen, you can let go of the power button. Ensure you keep holding the Volume Down Button

Safe Mode will now appear at the bottom left of the screen.

How to Exit Safe Mode (3 Ways) :

Press and hold the Power button for at least 6 seconds, then tap Restart.
Press and hold the Power + Volume Down buttons for at least 5 seconds
Swipe down from the top of the screen to access the Notification Panel, then tap on "Safe mode is on" To disable and restart.

Try turning on WiFi again, and if it works, then the problem may be with one of your installed apps - Consider deleting recently installed applications.

***Perform a Factory Reset***

Navigate to:

Settings
Tap on General Management
Tap on Reset
Factory data reset

Before performing this step, backup your important data as a factory reset deletes all data and brings the phone to its default settings.

There are times when you might want to turn off the wireless connectivity option on your Samsung device.

Navigate to settings
Tap on Connections.
You will get WiFi at the top.
Toggle the switch to change its state.
0 Likes
forestation
Asteroid
Options
Tablets

I tried everything except factory reset, and nothing worked. I am NOT going to do a factory reset. Frankly that suggestion is ridiculous. My tablet is new, why would I need to reset it already?

 

There are numerous complaints online about this issue so it's clear that the issue is not about my individual tablet but about all S9 series tabs. Please officially escalate this issue to Samsung tech support.

OoYORIoO
Sun
Options
Tablets
Done!
0 Likes
Samsung_Daddyb
Astronaut
Options
Tablets
Thousands of complaints. They hung up on me four times and then try to transfer me to 12 different people that didn't have a clue what they were talking about done everything they've asked us to do obviously the Galaxy tab 9 is a flop and they can't figure out their mistake but they will try to give you 800 fixes than trying to fix this for 2 months. They said they would give me a full refund I told them I was making payments and what about my trade-in they had no clue what to do about the trade-in so I would just lose it **bleep** poor Samsung. They should learn to accept their mistakes and correct them instead of make excuses.
Samsung_Daddyb
Astronaut
Options
Tablets
Me again just received my tablet back all problems fixed as they say had it on for 2 hours and internet in and out once again. I just want to inform people that I have nine other Samsung tablets in my house two which run on the Wi-Fi 6 and this is the only one again going in and out. Went into my Xfinity modem shut off the Wi-Fi 6 and found out this tablet won't connect to 2.5 or the 5 gigahertz. Tablet won't even find my home internet when the Wi-Fi 6 is shut off seems like a problem now sending it back for a second round.
Ahmet Aliko
Astronaut
Options
Tablets

Worst tablet I have ever bought constant connection issues and like you I have tried everything. I frankly waiting to convert my data to my laptop and sell this **bleep** to buy the newst iphone tablet. Don’t sell **bleep** you have not fully fixed. Terrible experience all around

0 Likes
OoYORIoO
Sun
Options
Tablets
@forestation
@Samsung_Moderator

I'm escalating this post per the users request to you for further assistance. Thank you!
I've escalated your post!1701964430226.jpg
0 Likes
MYDOGFIFI
Constellation
Options
Tablets
I will check them out, THX
0 Likes
MDarweash
Astronaut
Options
Tablets

I can confirm this issue on my Galaxy S9 Ultra. not only lose connection... but sometimes i can't see the 5Ghz networks at all if they are WiFi6. not only my router... every router i tries everywhere i go

0 Likes