JUMP TO SOLUTION Solved

Original topic:

RCS Suddenly Not Working After Switching Messages App

(Topic created: 02-08-2024 07:51 AM)
863 Views
Brittany15xz
Astronaut
Options
Galaxy S21
Hey all! So I thought I'd try out Google Messages but honestly, I didn't care for the lack of customization. So I quickly uninstalled Google Messages and switched back to Samsung Messages as my default app. Now my RCS Chat won't work for Samsung Messages. When I click 'Chat Settings', it pops up with registering for the service but I click start and it just says 'registration failed'. What's up with this? Please help. My carrier DOES support RCS...so now what???? 

image


1 Solution


Accepted Solutions
Solution
terminator9
Comet
Options
Galaxy S21
i looked this up for you. seems like google messaging is now the default app for all.samsung.. here is a vid where he explains what he did to get RCS on.the samsung messaging app.... hope it works for you. https://youtu.be/C1kFq1tCFdA?si=IGIQoMDzFqtyTnzA

View solution in context

7 Replies
Solution
terminator9
Comet
Options
Galaxy S21
i looked this up for you. seems like google messaging is now the default app for all.samsung.. here is a vid where he explains what he did to get RCS on.the samsung messaging app.... hope it works for you. https://youtu.be/C1kFq1tCFdA?si=IGIQoMDzFqtyTnzA
Brittany15xz
Astronaut
Options
Galaxy S21
Thank you!! This worked for me. I appreciate this so much. I've been researching how to fix it for 2 days.
terminator9
Comet
Options
Galaxy S21
i know it can be frustating... right.now i am dealing with my s23 ultra has been charging super fast 2.0 with my 45w charger and cable all along w no issues as of last update recently it wont do super fast charge anymore just fast charge now and its like a 20 min difference in.times...not awful but geez it was super fast before ...i looked it up alot are having same issue since update even the NEW s24 ultra people . that just got their phones hopefully samsung fixes the bug soon.... have a good day
0 Likes
Reply
Pizzauser
Cosmic Ray
Options
Galaxy S21
Can you explain what you did ? Do you have T-Mobile ? I have this problem too
0 Likes
Reply
Brittany15xz
Astronaut
Options
Galaxy S21
Sure but I have US Cellular not T-Mobile. Go to settings>connections>mobile networks>access point names. Then all I did was add another APN. I named it "Internet" and put the same APN name as the original one in my name. I restarted my phone and voila! It worked instantly. Let me know if this works for you...otherwise I do have another suggestion I saw online. Good luck!
Pizzauser
Cosmic Ray
Options
Galaxy S21
I tried it, didn't work but I noticed when Google messages is the default app I see the chat setting in Samsung messages app but when I make it the default messaging app the chat setting goes away in Samsung messaging app ?
0 Likes
Reply
Pizzauser
Cosmic Ray
Options
Galaxy S21
Thanks for the help also
0 Likes
Reply