JUMP TO SOLUTION Solved

Original topic:

Can't find 5ghz wifi after display repair

(Topic created: 09-01-2021 07:40 AM)
userB2LwLzDWOh
Astronaut
Options
Other Mobile Devices

I got my A52 5G repaired by Samsung because of a dead display (after 3 months and no physical damage), and after receiving it I noticed that the phone can't find any 5ghz wifi network, unless I am standing about 30 cm from the router (and still it disconnects). I tried with multiple networks (home, office, friends, etc), changing channels and rebooting both router and phone, and still nothing. My old A5 and my wife's Pixel 5 phone are getting a strong 5ghz signal anywhere in the house.

What can be the cause since before sending it for repair, I could connect to any 5ghz network without any problem, even from a long range? Its as if they removed or broke an antenna

0 Likes
Reply

1 Solution


Accepted Solutions
Solution
PBLivingston
Astronaut
Options
Other Mobile Devices
Sounds like the antenna wasn't properly reconnected. Probably want to send it in again, unfortunately.

Those tiny connections can be finicky to reconnect, but the person doing the repair should have tested a bunch of stuff after the repair like the camera and wireless connections because those usually need to be disconnected to replace the screen (depending on the phone model).

View solution in context

1 Reply
Solution
PBLivingston
Astronaut
Options
Other Mobile Devices
Sounds like the antenna wasn't properly reconnected. Probably want to send it in again, unfortunately.

Those tiny connections can be finicky to reconnect, but the person doing the repair should have tested a bunch of stuff after the repair like the camera and wireless connections because those usually need to be disconnected to replace the screen (depending on the phone model).