JUMP TO SOLUTION Solved

Original topic:

Can't change time zone & time on Galaxy Book Pro 360

(Topic created: 07-24-2021 02:13 AM)
usermNPMnr30NE
Astronaut
Options
Computers

I got this beast of a laptop 2 days ago and everything else seems to work as advertised. But it came set to Pacific (PST) time and I live in the Eastern time zone. I've changed it many times but there doesn't seem to be any way to make this laptop remember this. It always changes back to Pacific time and changes the clock to the PST time too!

In windows I've set the clock and time zone both back to EST 7 the local time many times, even trying it with the manual setting (no sync). For some reason when I close the window the clock switches back to PST time and sure enough, re-opening it will show the time zone went back too.

I even booted into BIOS, which let me change the time but had no way to set the zone. I set it to the EST time there and when I booted into windows it quickly switched over to PST time again. 😞

Hoping I don't have to move to California over this...

0 Likes

1 Solution


Accepted Solutions
Solution
SamsungGill
Samsung Moderator
Samsung Moderator
Options
Computers

Have you tried changing it via the registry or command prompt? It may be a permissions issue.

 

See if this forum post helps: Superuser Link

View solution in context

8 Replies
TheGalaxy
Honored Contributor
Options
Computers
See if there is any bios update for it
0 Likes
usermNPMnr30NE
Astronaut
Options
Computers

I've installed every update from both windows and Samsung. Is there somewhere else I should be looking for a bios update?

0 Likes
TheGalaxy
Honored Contributor
Options
Computers
Samsung PC support website
0 Likes
usermNPMnr30NE
Astronaut
Options
Computers

Looks like they just have a manual for me. 😞

https://www.samsung.com/us/support/downloads/?modelCode=NP950QDB-KB1US

0 Likes
Solution
SamsungGill
Samsung Moderator
Samsung Moderator
Options
Computers

Have you tried changing it via the registry or command prompt? It may be a permissions issue.

 

See if this forum post helps: Superuser Link

View solution in context

usermNPMnr30NE
Astronaut
Options
Computers

Yep, turned off the automatic time zones and went into the registry (windows shell) to set the time zone to "Eastern Standard Time" - when I came back out it was working great.

0 Likes
userSt9rAsLxpY
Astronaut
Options
Computers

Same problem.  Same solution.  Thanks @SamsungGill.  Although this seems like a pretty dumb thing to need to do.  I doubt many casual users would understand how to use a Windows PowerShell.  Samsung/Windows need to get that fixed.

0 Likes
SamsungGill
Samsung Moderator
Samsung Moderator
Options
Computers

You're welcome @userSt9rAsLxpY. It would be simpler if it was only a Samsung/Windows problem. It's basically a multiple manufacturers vs universal software problem. I've had the same issue with non-Samsung devices and non-Windows software. 

0 Likes