JUMP TO SOLUTION Solved

Original topic:

Pandora Keeps Opening & Running in the Background

(Topic created: 12-16-2023 01:50 PM)
15512 Views
LushMelody
Cosmic Ray
Options
Galaxy Note Phones

Firstly, this issue is different than the Spotify issue.

Original subject title: Pandora Media Output Won't Go Away

Also: Is there a way to keep the media player on the Watch 6 from automatically opening when media is played on the phone?

Note: I have Pandora Premium paid account, and have been using Pandora since 2008. Even after the incident with the community mods, I won't switch. I've invested a touch over 15 years to my stations, and 6 years into my playlists. The cost is the same as Spotify.

That said... After closing Pandora, the 'Media Output' bar in the notification pulldown doesn't close unless manually swiped away. After being swiped away/dismissed, Pandora opens back up, on it's own, and the 'Media Output' notification comes right back with the new song (thankfully it doesn't auto play 90% of the time anymore, which was a Pandora issue now said to be resolved).

Different scenarios:

1: Swipe Close Pandora > Swipe Away Output Notification > Stop Pandora 'Active in Background' > Media Output Shows Output Device Name with 'Unknown' over 'Unknown' instead of Artist and Song Title > Swipe Away Unknown Output Notification > Pandora Opens Again Within an Hour.

2: Swipe Closed Pandora > Immediately Stop Pandora from Active in Background > Swipe Away Media Output Notification > Pandora Widget Shows as Still Open but Paused > Media Output Notification Comes Back Within Minutes.

3. Swipe Closed Pandora > Do Nothing > Pandora Continues Running Indefinitely w/ Unchanged Media Output Notification.

Troubleshooting steps taken (Note- the Pandora setting 'Auto Start' is verified off)

  • Cleared App Cache
  • Cleared App Data
  • Restarted Device (Note 20 Ultra 5G)
  • Turned Off Media & Devices Notification (still shows when off)
  • Put Pandora into 'Sleeping Apps' in Device Care
  • Put Pandora into 'Deep Sleeping Apps' in Device Care
  • Turn Off Background Use Permission in App Settings
  • Uninstalled Pandora > Reinstalled
  • Uninstalled Pandora > Smart Switch Backup (& manual backup via both Samsung account and Google, as well as backing up files manually on separate drive/device) > Factory Reset > Smart Switch Restore > Reinstall Pandora
  • --- Factory Reset > Samsung Account Restore > Reinstall Pandora
  • --- Factory Reset > Google Account Restore > Reinstall Pandora
  • --- Factory Reset > Manually Restore Personal Files, Settings, etc., & Manually Reinstalling Apps > Reinstall Pandora

NONE of these resolved the issue, and Pandora keeps opening and media output notification won't go away no matter what I do. Please help, it's killing my brand new Watch 6 battery as the media player is constantly running, because Pandora is always running. I'm not sure if the media output is opening Pandora, creating a vicious cycle, or if Pandora is starting the cycle by opening itself.

Other observations: When I connect a Bluetooth audio device, Pandora opens and starts playing immediately. I've made sure ALL auto play/start settings are turned off. As well as (much less often now) sometimes, after getting home and my phone auto connects to my Wi-Fi, Pandora will start playing. Sometimes I have my media volume all the way down and don't hear it, but this auto play issue has been said to be resolved by Pandora engineers, and it's a very rare occurrence since the latest update, but does still happen. The support article from Pandora's Community site regarding this issue was marked as spam and has been deleted by the mods. The mods continue to delete my posts (which was a copy and paste of this post), so my only recourse for support is through Samsung Community.

Any ideas or troubleshooting steps I missed or overlooked would be greatly appreciated

Technical Info:

  • Device - Samsung Unlocked Galaxy Note 20 Ultra 5G (branded, not carrier specific)
  • Model - SM-N968U1
  • Model Code - SM-N968UZKATMB
  • One UI Version - 5.1
  • Android Version - 13
  • Build Number - TP1A.220624.014.N968U1UES5HWJ4
  • Carrier - T-Mobile
  • Pandora Version - 2310.1
  • •App Last Updated - October 16th 2023

If further information is needed, I'm happy to provide it.

1 Solution


Accepted Solutions
Solution
LushMelody
Cosmic Ray
Options
Galaxy Note Phones

New thread for Watch 6 specific media player issue.

Pandora seems to have resolved the app constantly opening with the latest update. However, this hasn't fixed the issue with my Galaxy Watch 6.

View solution in context

17 Replies
catfane
Asteroid
Options
Galaxy Note Phones
Sorry, I do not have a solution for you. I am having the opposite problem. Pandora will not play more than 1 song in the background since the latest update. Is there a way to revert to the previous version of Pandora?
0 Likes
Reply
LushMelody
Cosmic Ray
Options
Galaxy Note Phones

I don't think so, but you might want to check your background use settings.

Settings > Apps > Pandora > Battery > then select 'Optimized' or 'Unrestricted'

If that doesn't work, check device care:

Settings > Battery and Device Care

  • Tap the line graph looking icon in the top right > check the 'App History Issue'
  • -- I have 2 'frequent crashes' events. Check to make sure you're not having constant issues
  • Tap 'Check Sleeping Apps' > Look for Pandora. If you see it, tap the top right 3 dot menu icon > select 'Remove' > check the circle next to Pandora > tap 'Remove'

If this doesn't help, let me know and I'll give you some more options. 🙂

I've spent most of my life doing tech support, starting with DOS (yes, I'm dating myself here 😅)

0 Likes
Reply
catfane
Asteroid
Options
Galaxy Note Phones
🤣 thank you. I will try that.
0 Likes
Reply
O-dog66
Cosmic Ray
Options
Galaxy Note Phones
I have had that problem with the Pandora app. I went to Apps and forced closed it. It didn't come back after that.
SoeurSage
Constellation
Options
Galaxy Note Phones
See, and I've tried that and it STILL opens itself in the background.
0 Likes
Reply
usersecVjiWIdH
Constellation
Options
Galaxy Note Phones
I have had the same problem for months! Even when I gave my phone on silent, I will be sitting at work and out if no where pandora comes on and blasts music in my office! It gets me in trouble every time and I have no control over it
0 Likes
Reply
LushMelody
Cosmic Ray
Options
Galaxy Note Phones

Putting your phone on silent doesn't change the media volume. However, Pandora support says they have fixed it automatically playing in the background. Double check for an update in the Google Play Store. If it's fully up-to-date, then check your settings and try turning off all auto-play settings in the app. Should be under My Profile > Settings > Advanced.

In the meantime, check that your media volume is all the way down before you start work.

0 Likes
Reply
Options
Galaxy Note Phones
I've never seen an app turn on by itself after being put into "deep sleep". I don't have a watch, so I'm not knowledgeable about the connections it makes outside the phone, but my guess would be to see if the watch is triggering Pandora to turn on. Have you tried not using the watch to see if Pandora turns on? If it doesn't, then you know the watch is the culprit.
0 Likes
Reply
LushMelody
Cosmic Ray
Options
Galaxy Note Phones

Yes, the watch is new. This has been happening for many months. I have disconnected my previous watch (Galaxy Active 2, but the media player wasn't always running because of this issue. It only opened the media player when Pandora was actively playing music) back when I had the old one. I have also turned off the Galaxy Watch 6 and repeated all troubleshooting steps. The phone is causing the issue on the watch (only because the watch constantly thinks the media player should be open), but the watch is not effecting the phone/app.

I apricate that point of view though. It's a good suggestion.

0 Likes
Reply