JUMP TO SOLUTION Solved

Original topic:

Samsung keyboard doesn't insert actual punctuation mark when "voice typing"

(Topic created: 07-03-2023 03:39 PM)
26366 Views
localhero
Asteroid
Options
Galaxy S Phones

My phone recently updated to Android 12 and Gboard doesn't work well for me anymore.  I switched to the Samsung Keyboard and there's a lot to like about it except for the "voice typing".  It does get things somewhat accurate (I'm hoping it's learning and improving) and while it does input some punctuation, it always inputs the word "period" instead of the punctuation mark.   Pretty frustrating to stop nearly every sentence to correct that.

Is there a fix for that?  I've spent some time with the settings and would respond to other posts talking about similar issues but they've all been closed.

1 Solution


Accepted Solutions
Solution
localhero
Asteroid
Options
Galaxy S Phones

We definitely have some setting differences.  Under "General Management" (I don't have "System") I was able to find "Keyboard list and default" and under that I saw that Samsung Voice input was checked along with "Google voice typing", "Google Voice Typing (Legacy)" and "Gboard".  Unchecking "Samsung voice input" now allows me to bring up Google voice typing when I long press the space bar without losing the Samsung keyboard.   I bow to your superior knowledge. 😁

 

View solution in context

6 Replies
JBTechfanatic
Black Hole
Options
Galaxy S Phones
Follow these steps to use Samsung keyboard but Google voice will fix your issues with typing Screenshot_20230703_172359_Samsung Members.jpgScreenshot_20230703_172415_Samsung Members.jpgScreenshot_20230703_172430_Samsung Keyboard.jpgScreenshot_20230703_172437_Samsung Keyboard.jpg
localhero
Asteroid
Options
Galaxy S Phones

JB, that looks great and I *almost* have the same menu options.   Under settings I get this:

Screenshot_20230704-005250_Samsung Keyboard.jpg

Under Swipe, Touch, Feedback I get this:

Screenshot_20230704-005309_Samsung Keyboard.jpg

 So "Voice input" is there and I had great hopes but all that brought up was this:

Screenshot_20230704-005316_Samsung Keyboard.jpg

 Which allows me to long press the spacebar and open up the (not-so-good) Samsung voice typing.   I did figure out through your post that I can click on the keyboard symbol in the lower right and choose Google voice typing which does give me the better voice option.  It's not one click but it's a workable workaround. Thanks!

Not sure why my device (Samsung S10) would have different menu options except that i'm running Android 12 where as you might be running 13?  I don't think the S10 is upgradable to 13.

JBTechfanatic
Black Hole
Options
Galaxy S Phones
Is still there to make it permanent it's just in a different spot let's try this Step 1: Open the Settings app.

Step 2: Click on 'System. ...

Step 3: Click 'Languages & input'.

Step 4: Click 'Virtual keyboard'.

Step 5: Click 'Gboard'.

Step 6: Click 'Voice typing'.

Step 7: Tick 'Use voice typing' to turn it on.

Solution
localhero
Asteroid
Options
Galaxy S Phones

We definitely have some setting differences.  Under "General Management" (I don't have "System") I was able to find "Keyboard list and default" and under that I saw that Samsung Voice input was checked along with "Google voice typing", "Google Voice Typing (Legacy)" and "Gboard".  Unchecking "Samsung voice input" now allows me to bring up Google voice typing when I long press the space bar without losing the Samsung keyboard.   I bow to your superior knowledge. 😁

 

JBTechfanatic
Black Hole
Options
Galaxy S Phones
That's awesome I think this will really improve your experience
localhero
Asteroid
Options
Galaxy S Phones

It most definitely does!  Thanks again.  

0 Likes
Reply