cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Constellation

Show Keyboard Button grayed out on Galaxy S10 Plus with OneUI 2.0

JUMP TO SOLUTION

Hi all,

 

So today I got a notification that Android 10 (or OneUI 2.0) was available for installation. Of course, as I really want the better Dark Mode, I installed it immediately. So far all is working well, but I'm not able to switch off or on the Show Keyboard Button in the On-screen keyboard settings since the button is fully grayed-out. I also tried doing the same in Safe Mode, but wasn't able to switch it on or off there either. I tried uninstalling SwiftKey keyboard to is if there might be an issue due to this third party keyboard, but that also doesn't solve the issue (not even after a reboot of the phone), so I reinstalled it again.

 

Screenshot_20191205-144054_Settings.jpg

 

The keyboard navigation bar takes some space from the bottom of the phone. It's not a huge issue, but I had it disabled in Android 9.0, but cannot disable it now (it was turned back on during the update to Android 10 I guess).

 

Is there anyway to get this button working again, and of course the feature it represents?

 

Thanks in advance.

1 SOLUTION

Accepted Solutions
Highlighted
Constellation

Re: Show Keyboard Button grayed out on Galaxy S10 Plus with OneUI 2.0

JUMP TO SOLUTION

I found the solution. I first had to reenable the Navigation bar in the Display settings (I was using Full screen gestures rather than the navigation buttons). Once the navigation bar was enabled, the Show Keyboard Button was working again. Disabling the Navigation bar also grayed out the Show Keyboard Button again.

 

So, issue solved Smiley Happy 

View solution in original post

Reply
Loading...
6 REPLIES 6
Highlighted
Samsung Care Ambassador

Re: Show Keyboard Button grayed out on Galaxy S10 Plus with OneUI 2.0

JUMP TO SOLUTION

A few things that you could try.

 

First click the "Default keyboard" button and the option to "Show keyboard button" is there.

 

Another option is to delete the cache for Swiftkey keyboard. 

 

Another option is to wipe the device cache partition. 

Reply
Loading...
Highlighted
Constellation

Re: Show Keyboard Button grayed out on Galaxy S10 Plus with OneUI 2.0

JUMP TO SOLUTION

I found the solution. I first had to reenable the Navigation bar in the Display settings (I was using Full screen gestures rather than the navigation buttons). Once the navigation bar was enabled, the Show Keyboard Button was working again. Disabling the Navigation bar also grayed out the Show Keyboard Button again.

 

So, issue solved Smiley Happy 

View solution in original post

Reply
Loading...
Highlighted
Constellation

Re: Show Keyboard Button grayed out on Galaxy S10 Plus with OneUI 2.0

JUMP TO SOLUTION

Show button to hide keyboard needs to be off to . Still seem a bit of trouble that you have to revert to original navigation buttons than switch off keyboard button and hide keyboard button than revert back to gestures . Well at least my bottom part of keyboard it's no longer overlapped by this stupid panel . Don't see really point of since you can change languages etc with your space button if you using few languages . Screenshot_20191221-221019_Settings.jpg

 

Screenshot_20191221-220836_Firefox.jpg

That's how mine looked before changes.  And thus is how it look after all that reverting and putting back .Screenshot_20191221-222738_Firefox.jpg

 

Reply
Loading...
Highlighted
Constellation

Re: Show Keyboard Button grayed out on Galaxy S10 Plus with OneUI 2.0

JUMP TO SOLUTION

If you go to Display - Navigation bar, there you can unable "Show button to hide keyboard"

It worked for me. 

Reply
Loading...
Highlighted
Astronaut

Re: Show Keyboard Button grayed out on Galaxy S10 Plus with OneUI 2.0

JUMP TO SOLUTION

This did it for me! Thanks! I was getting pretty frustrated after the latest update caused that bar to show up. 

Reply
Loading...
Highlighted
Constellation

Re: Show Keyboard Button grayed out on Galaxy S10 Plus with OneUI 2.0

JUMP TO SOLUTION

Thank you so much! This is the first thing everyone should try since it's the easiest fix. 

Reply
Loading...